Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
4G not working on Thunderbolt
cburt
Member

My Thunderbolt hasn't been using the 4G network even though it is available (a family member has the same phone and, side-by-side, hers shows 4G on the display and mine doesn't.  I had been thinking that it was because I also have it set up for WiFi, but I never see 4G.  Any Ideas?

Labels (1)
0 Likes
Re: 4G not working on Thunderbolt
wayne8821212
Member

Since you have probably not "enhanced" your phone's capabilities by rooting, you might try bringing up your dial pad and keying in    *#*#4636#*#* then selecting "Phone Information" .....On the next screen you should scroll down until you see a drop down associated with "Set preferred network type" If you are in a 4G area you would choose "CDMA + LTE/EvDo auto" or "LTE mode" but  if you are not in an LTE area for an extended time, you can choose EvDo only (to save battery). Sometime just turning of LTE and turning it back on will make it connect properly. Connecting to wifi will also save you battery by turning off 3G and 4G.

0 Likes
Re: 4G not working on Thunderbolt
DionM_VZW
Verizon Employee

Great idea, wayne8821212!

 

Hey, dburt... if you're still not getting 4G signal/service, please let me know. You can send me a personal message if you like. Thanks!

0 Likes
Re: 4G not working on Thunderbolt
dmjepp
Member

I have been having the same problem for going on two months and have heard all of the "fixes" offered by Verizon. So far nothing has worked. Just got a CLNR from them yesterday which actually performed worse than my phone. So it will be going back instead of my phone. Now I am supposed to go back to the company store and have them give me a new SIM card which will magically make everything all better. At this point I am very skeptical of anything they tell me.

 

Whats worse is that I got two "identical" T-Bolts on the same visit and the one for my wife works like a champ wherever we go. I can be sitting right next to her and feel lucky to be at 1x connection speed while she is rocking a steady 4G. Makes it all the more frustrating when it appears to be a hit or miss problem that does not affect everyone. At least if it were every phone I could believe they are doing more to rectify the problem. But there are posts scattered across many boards regarding this issue and they all tell the same story about being given refurbs, doing resets, changing SIMs and so on to no avail. I'm getting real close to chucking the thing through a wall but have managed to remain patient so far. All in the hopes that someone gives us an honest answer as to why the thing worked so well for a little while but is crap since their national outage and the following update they pushed out. I want for the glory days that only lasted a week or so after openng the box!

0 Likes
Re: 4G not working on Thunderbolt
AnthonyTa_VZW
Verizon Employee

dmjepp wrote:

I have been having the same problem for going on two months and have heard all of the "fixes" offered by Verizon. So far nothing has worked. Just got a CLNR from them yesterday which actually performed worse than my phone. So it will be going back instead of my phone. Now I am supposed to go back to the company store and have them give me a new SIM card which will magically make everything all better. At this point I am very skeptical of anything they tell me.

 

Whats worse is that I got two "identical" T-Bolts on the same visit and the one for my wife works like a champ wherever we go. I can be sitting right next to her and feel lucky to be at 1x connection speed while she is rocking a steady 4G. Makes it all the more frustrating when it appears to be a hit or miss problem that does not affect everyone. At least if it were every phone I could believe they are doing more to rectify the problem. But there are posts scattered across many boards regarding this issue and they all tell the same story about being given refurbs, doing resets, changing SIMs and so on to no avail. I'm getting real close to chucking the thing through a wall but have managed to remain patient so far. All in the hopes that someone gives us an honest answer as to why the thing worked so well for a little while but is crap since their national outage and the following update they pushed out. I want for the glory days that only lasted a week or so after openng the box!


dmjepp,

 

I understand your frustrations!  Just want you to know we are aware of the issues with the Thunderbolt 4G, and are working diligently to come up with a permanent fix.

 

Let me know how the new SIM works for you!

0 Likes
Re: 4G not working on Thunderbolt
MNMNT
Member

Where is this fix? My 4G doesn't work going through the MD/DC/VA metropolitan area. I drive from Columbia, MD to DC to Alexandria, VA every morning and I got 4g for 10 seconds. My gps doesn't work either. It says I'm in the Potomac River - and the navigation directions turn by turn feature doesn't work.

0 Likes