How I got my 2011 MacBook Pro (17") to work with the UML290 without any 'hackery'
Contributor - Level 1

Frustrated and fed up with waiting for Verizon to finally fully support an operating system that is almost two and a half years old now, I decided to experiment and play around with things myself.  Here is what I learned:


For some reason, the "dial your number" network hack that people got working didn't work for me.  I set up everything as the tutorials all said (GRPS (GSM/2G), APN to "vzwinternet", dial your phone number, user name is, password is vzw, CID 3, etc).  It just would not work for me.  Maybe it's becasue I had my UML290 hooked up to a Windows 7 box that updated the firmware, which may have rendered this 'hack' inept.  I don't know; all I know as that, despite trying to get this method to work for several days, I was never able to get it to work.


There was no way, as far as I could see, to force the Verizon Access Manager (VZAM) software to run in 32bit mode as you can with most other programs.  Typically, you can hilight a program, press CMD+I and select a checkbox to run an app in 32bit mode, but no such option existed for VZAM (for whatever reason).


Finally, I found a workaround to get the modem working until Verizon gets their act together and makes VZAM work with 64bit OS X.  Here's how:


  1. Completely power off your computer. 
  2. Depress and hold the "3" key and the "2" key (at the top of your keyboard) at the same time BEFORE pressing the power button.
  3. Press the power button while continuing to hold the "3" key and the "2" key.
  4. Continue to hold the "3" key and the "2" key until the login prompt comes up.
  5. Log in as normal (you may have to remove a bunch of characters from the password field; just CMD+A and delete what's in there and type your password as usual).
After following the steps above, you should have forced your Mac to run in 32bit mode.  Run VZAM as normal and you should have no trouble connecting to the 4G/3G network.
Note: This measure is TEMPORARY, and will force OS X to load the 32bit kernel instead of the default 64bit kernel (if your MacBook is set up to use the 64bit kernel by default).  This change will be undone at your next restart provided you do not hold down the "3" key and the "2" key.
Note: If you used previously posted "dial-up" methods to get your modem working on your Mac, you will need to undo the 'damage' to your settings that that workaround caused.  Please see my post here (post 14) for detailed instructions on how to do so.
Note: This is a temporary solution that carries with it some down sides:
  1. True 64bit support offers higher levels of security than 32bit.
  2. You will likely be unable to use more than 3GB of of memory as a 32bit OS cannot, by nature, address that much RAM.
Please let me know if you have any problems.  I can't promise I can help, but I'll do my best.


Labels (1)
Re: How I got my 2011 MacBook Pro (17") to work with the UML290 without any 'hackery'
Contributor - Level 3

You should have put "64-bit" in your title. That hackery is YOUR OWN COMPUTER and nothing to do with VZW. Yeah of course putting your computer into 32-bit mode it works with the 32-bit mode app. 

Re: How I got my 2011 MacBook Pro (17") to work with the UML290 without any 'hackery'
Contributor - Level 1

Hey, it's a simple fix that should give most people what they want until there is full VZW support: the ability to use their card with the VZAM software.  I didn't see anyone else offering that suggestion...  If you don't want to use it, you don't have to.


At the very least, this does seem to prove the theory that this is an issue with the 32/64bit compatability that some have refuted.