Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Is there a way to get my pantech uml290 to automatically reconnect when my windows 7 pc wakes up?
outonalimb
Member

I have my windows 7 pro desktop set to go to sleep every hour (control panel, power options). When it wakes up, the pantech uml290 mifi device is invariably disconnected. I used to just restart the computer, but I found if I go into device manager (right-click my computer, properties, device manager) and click on network and click action, then scan for hardware changes it will reconnect it. But there should be a way to set the device so it reconnects automatically.

Labels (1)
0 Likes
1 Solution

Correct Answers
Re: Is there a way to get my pantech uml290 to automatically reconnect when my windows 7 pc wakes up?
outonalimb
Member

Update-PROBLEM FIXED by verizon support. I called my local verizon wireless store, who quickly got me tech support after running through a few things. I didn't know you could disable power management for just one device, but verizon tech support did! So you go into device manager, expand universal serial bus controllers, right click the first "root hub", click the power tab, and see if your device shows up. If it doesn't, continue this process through all the root hubs until it does.

When you find it, select it, and click the power management tab on the far right. Uncheck "allow the computer to turn off this device to save power". Restart the computer to save this setting. Then test it by putting the computer to sleep.

It did take about 30 seconds until the pantech uml 290 was connected, but it connected successfully three times in a row. I'm very happy with both the verizon store and verizon tech support. They were both very helpful and pleasant to talk t, and efficiently resolved the problem. I still think you pay too much for mobile broadband, and am a little put off that the problem existed in the first place, but I'm very happy to have this problem resolved.

One other piece of info. I got was that there is an upgrade, pantech 295 usb modem for only 30.00. So if I have any more problems I'll just try that.  (It's still a wired, not wireless device, which I prefer.)

View solution in original post

0 Likes
Re: Is there a way to get my pantech uml290 to automatically reconnect when my windows 7 pc wakes up?
outonalimb
Member

Is anyone else having this problem? Again, my windows 7 pro computer is in sleep mode, and when it wakes up, the pantech device doesn't work.

I  have a little programming experience, so I did automate it somewhat by downloading a program called 'devcon' that will let you scan hardware from a command line. The command line is Devcon rescan.  I had to jump through a few hoops, of course, since Devcon is a Microsoft program.

I downloaded it from Download Devcon for Windows 7 » IT Dribble . Then, of course, Access was denied. You can get around this by creating a text file in notepad, and renaming it something like rundevcon.bat. Then you need to put the devcon rescan line in that file. I copied devcon straight to drive c:\, so my line was specifically

c:\devcon rescan. Then you just need to doubleclick the batch file you have made, and 3 minutes later your pantech should be connected. All this just to get something that should be working, working!

THIS AND THE OTHER PROBLEMS I SEE ON HERE NEED A FIX! Whom should we complain to about these problems?? It's not like we don't pay enough for mobile broadband!

0 Likes
Re: Is there a way to get my pantech uml290 to automatically reconnect when my windows 7 pc wakes up?
outonalimb
Member

Update-PROBLEM FIXED by verizon support. I called my local verizon wireless store, who quickly got me tech support after running through a few things. I didn't know you could disable power management for just one device, but verizon tech support did! So you go into device manager, expand universal serial bus controllers, right click the first "root hub", click the power tab, and see if your device shows up. If it doesn't, continue this process through all the root hubs until it does.

When you find it, select it, and click the power management tab on the far right. Uncheck "allow the computer to turn off this device to save power". Restart the computer to save this setting. Then test it by putting the computer to sleep.

It did take about 30 seconds until the pantech uml 290 was connected, but it connected successfully three times in a row. I'm very happy with both the verizon store and verizon tech support. They were both very helpful and pleasant to talk t, and efficiently resolved the problem. I still think you pay too much for mobile broadband, and am a little put off that the problem existed in the first place, but I'm very happy to have this problem resolved.

One other piece of info. I got was that there is an upgrade, pantech 295 usb modem for only 30.00. So if I have any more problems I'll just try that.  (It's still a wired, not wireless device, which I prefer.)

View solution in original post

0 Likes