Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
Samsung SCH-LC11 4G MIFI mobile hotspot - First Impressions #2
ITKen
Newbie

Yesterday, I received two Samsung 4G MIFIs to add to our corporate plan.  These are also to serve as test units for evaluation for a possible upgrade of our 14 other 3G data lines (PCMCIA). Here are my first thoughts and impressions regarding this device.  I apologize in advance for the length of the post and some of the more simple descriptions that might not need to be included.  I've found that sometimes these minor steps become helpful to others with troubleshooting issues.  I've found that they sometimes end up as "AH HA!" moments.

 

Out of the box:  As soon as I opened the box, I was impressed by the size and styling of the adapter.  Having not used or even seen one in person, it was a bit smaller than I was expecting.  It's certainly small enough to fit into a shirt or pants pocket. For those that have not seen one, it's approximately half the height of a pack of cigarettes lying down.

 

Initial Setup:  In general, this couldn't have been much simpler.  After following the basic instructions (install battery, power on, connect and login), it was ready go.  No activation phone number to call like I'm used to.  *Reading other posts, it looks like these adapters don't always come pre-configured like mine was.  It already had the SIM card installed and was ready to go.  This must be a friendly service my local distributor does.

 

I love the fact that this unit does not need VZAccess Manager to run.  Simply plugging the USB cable into a laptop will start charging the battery without putting it into a "single user" mode like other adaptors do.  This simplifies things for IT administrators, as you don't have to explain multiple scenarios for how to use the device.  Plus there are fewer options for the end user to mess things up. 

 

Advanced Setup: This is where things start getting fun.  My first task was to change the SSID and security key.  I navigate over to the Network->WIFI tab. It took me a minute to figure out the whole profile thing, but when I went to make my changes on the "Manual Configuration" side, something still seemed out of place.  I had drop down menus that didn't have any text in its fields.

 

                  Blank Field

 

This lead to a bit more confusion as to how the profiles worked.  I decided to change things up and switch from IE 8.0.7601 to FireFox 4.0.  Using FireFox, everything looked in place.  I proceeded to configure the settings and then selected "apply".  Apparently this wasn't the option I needed as all my settings reverted back.  It looks like you need to select "Update Profile" first before applying the active profile.  Great, now we are up and running! 

 

Note: Both of my devices are running AP/Modem firmware: EC04

 

Speed Test:  Curious to see how these new devices performed, I ran a number of speed tests while connected.  My area has yet to be 4G enabled, so I wasn't expecting much in terms of an improvement with the 3G.  On average I was getting 1mbps down and 500kbps up.  This is actually slower than our current 3G cards that average 1.5mbps down and 768kbps up.  Hopefully we get the 4G service sooner rather than later. 

 

Deal Breaker:  VPN.  For my company, we use Windows VPN access.  I spent a little time trying to connect to the VPN with this adaptor.  For some reason I could not get past the authentication.  I tried from multiple machines, using different OSes, still no luck.  I contemplated making some changes on the server side, but decided against it as all other VPN connections (including 3G adaptors) were fine.  That led me to these forums in search of an answer.  More specifically, the current post on the exact same issue I was seeing.

 

http://community.vzw.com/t5/4G-Discussion/Samsung-SCH-LC11-Blocks-Microsoft-VPN/td-p/489618

 

I will do some additional testing, including some changes on the VPN server, but might have to send these back.

 

Summary:  They look like great little devices, but in my opinion, are currently not quite suited towards some business environments.  This could perhaps change with a firmware update or two.

Labels (1)
0 Likes