Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring your phone. Plus, get the incredible iPhone 13 Pro on us. Online only. With select 5G Unlimited plans. Ends 12.5. Buy now
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
***Announcement: Early next week, we’ll be merging the current Fios and Wireless Communities into the all new Verizon Community! Beginning the evening of Sunday 12/4, both Communities will be placed in read-only mode. You’ll still be able to visit the Communities and browse content, but login will be disabled. On the afternoon of Monday 12/5, all users will be able to log into the new Verizon Community. We expect the new Community to be fully functional the morning of Friday 12/9. Additional details can be found in the Announcements board and under Featured Topics!
The service provided by the Samsung SCH-LC11 Mi-Fi device, and/or the 4G LTE service, is unusable.
ophidian14
Member

I got the Samsung SCH-LC11 Mi-Fi device and 4G LTE service from Verizon about one week ago here in the Chicago area.

(Note: the first thing I did was update to the latest firmware (EF07) per the Samsung website.)

I am using it with my AT&T iPhone 4 with "Cellular Data" on the phone turned off completely.

I ran all the speed tests, 10 megabit up/down, wow, great.

Unfortunately, there are at least two major problems with it:

1)  I noticed almost immediately that push emails stopped coming to my iPhone after a few minutes.

After looking into this in more detail I realized the following:

   a)  The modem inside the Mi-Fi device is being assigned a 10-Net / "carrier-grade NAT" IP address, not a real Internet IP address.  Fine, I don't really care as long as it works.  I am not trying to use a VPN, or do VoIP, or run some webcam somewhere.  In other words I'm not a "revenue leak" in Verizon "parlance" (I worked at Motorola during the OBEX fiasco days), but it's nice to know I'm being treated as such right off the bat.

   b)  The "carrier grade NAT" appears to have a TCP timeout of no more than two minutes.  I verified this by opening a telnet session to somewhere and not typing something for two minutes.  After the two minutes I typed another character, but it never got echoed back and the connection was dropped.  After waiting only a minute and a half, it lagged a little but sprang back to life.

   c)  Problem is, push email relies on having an open TCP connection that is idle the vast majority of time.  When an email comes in, the Exchange ActiveSync server sends a message back out to the device (over the existing connection) saying the mailbox has changed.  Unfortunately, after two minutes of idle, the "carrier grade NAT" has dropped the translation entry a long time ago, so the connection is dead.

So I emailed support about this.  (the ticket is "WFM87599752").

In the first round they told me to go look in the device's settings @ http://192.168.1.1.  Yeah, did that already.

In round two, they blamed the dormancy timer.  That's obviously not it, since the modem is layer two and knows nothing about TCP at all.  Just to be sure though, I performed the test again, but this time I had a DOS window pinging Yahoo repeatedly so the modem wouldn't become dormant.  Problem still happened.  I saved the Wireshark PCAP here so anyone can see:  http://home.comcast.net/~abcbwtxyz/two_minutes.pcap  Frame #339 is where I try to type again, never to hear back.

2)  The other problem is that as soon as a second person connects to the Mi-fi device over Wi-fi, the first person gets dropped almost immediately, and can't even reconnect again afterward.  I mean, really?  Made this video to illustrate:  http://www.youtube.com/watch?v=Iadz4DGXFRM

...

So, can someone help?  I know I'm not the only one having these problems; I sent the support alias the following links just as examples, there are many more:

http://himself.wordpress.com/2011/04/30/verizon-wireless-issuing-private-ip-addresses-to-3g-customer...


http://www.broadbandreports.com/forum/remark,26067018


http://www.droidforums.net/forum/droid-x-tech-support/101185-droid-x-verizon-3g-assigning-10-nat-ips...

-Chris

Labels (1)
0 Likes
Re: The service provided by the Samsung SCH-LC11 Mi-Fi device, and/or the 4G LTE service, is unusable.
ophidian14
Member

So just to follow up on this.  I called to cancel today.  The CSR wanted me to talk to tech support about my problems and talk me out of cancelling so I said fine.  Summary of conversation:

1)  Immediate acknowledgment that the two minute timeout of idle connections is by design, and no dispute that it breaks push email.

2)  Disagreement with the claim that a second person logging on kicks off the first, even though I offered proof.  Dismissed my point that other people have seen the same exact thing, saying that if you look up problems other people are having on the Internet, people say anything and everything.

Anyway, I continued with the cancellation; to their credit, they waived the activation fee and credited me for "time served", so I won't owe anything.  I did appreciate that.

0 Likes