Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
VPN
diligent_consumer

I am having signif slowness issues when I have some types of VPNs enabled on Verizon LTE Internet.  on work laptop, GlobalProtect VPN is dog-slow, but Cisco AnyConnect works just fine.  (unfortunately, GlobalProtect is more current tech and is the solution my employer is moving toward.)

on my home laptop (owned by me), Malwarebytes VPN is dog-slow, too.  and before you blame the VPN, you should know there are no issues w/Malwarebytes VPN when I used it with AT&T DSL.  I have found several links online regarding Verizon's propensity for either intentionally throttling certain types of VPN traffic and/or just having issues with handling it.

w/o VPNs I get mid-40sMbps download and 6 upload....but with Mbytes and GlobalProtect, I get 2Mbps download and typically unimpacted upload speeds.  from other online forums, I have learned that Verizon has historically not handled ALGs very well, and it was suggested to disable them (in the router settings).  however, when I did so, it also forced the firewall setting from medium to maximum, which caused Malwarebytes VPN to not be able to connect at all--consistently so, meaning it could never connect.

my home computer's VPN works fine on another ISP's service (AT&T), and my employer's VPN works on other employees' home internet service (ie, it is only having issues with mine, and I seem to be the only person in our company with Verizon LTE service).  this would seem to point rather definitively to verizon lte internet as being the issue.

what help can you provide?  phone support is very inadequate--they just want to blame the VPN provider(s).

I am unable to reply to the thread found at ...

https://community.verizon.com/t5/Verizon-4G-LTE-Router/Home-LTE-5g-Slow-VPN/m-p/1242207

also, other threads elsewhere online ...

https://www.reddit.com/r/verizon/comments/ssmp6l/5glte_home_internet_vpn_issue/

the following thread was a suggested workaround, involving disabling the ALG settings (however, it did not work -- because changing the ALG settings also changed the firewall setting to maximum, which apparently caused my Mbytes VPN to not be able to connect at all) ...

https://www.reddit.com/r/Rural_Internet/comments/rcujxz/fixed_an_issue_with_verizon_lte_home_interne...

I cannot stress enough that Verizon's LTE router seems to be the issue--recall that my home computer's VPN works fine on another ISP's service (AT&T), and my employer's VPN works on other employees' home internet service (ie, it is only having issues with mine, and I seem to be the only person in our company with Verizon LTE service).

how does one get these two VPNs to work on your LTE home internet?  are there settings to get the router to do the right thing?

0 Likes