Verizon LTE is Terrible in Pittsburgh
kingzope
Newbie

I'm getting absolutely awful LTE speeds in Pittsburgh and upon browsing many other forums, I noticed I'm not the only one and the iPhone isn't the only phone.  There is definitely a problem with LTE in Pittsburgh and I would like to know if anyone can verify the same problems as myself and well as hopefully have someone from Verizon validate the issue and get someone to work on it.

I believe Verizon guarantees a certain speed with LTE and when I get .51Mbps down with 5 bars of LTE I think it deserves a response.  Switching carriers is too much of a pain to deal with and honestly I haven't dropped a call since I switched to Verizon so I'd rather this be remedied then go through the pain of switching.

I will run speed tests tonight and this weekend and post up screenshots to update the thread.

Labels (1)
0 Likes
Reply
4 Replies
tuckgergg
Newbie

I have the same problem in Pittsburgh. I have the Razr Maxx. Whenever I'm on 4g, it's fine, but my phone consistently defaults back to 3g, and the 3g speeds are terrible. I've run speed tests and on 3g, I get 10 - 20 kbps. I've spoken with Verizon reps and they've told me we are supposed to have full 4g signal in Pittsburgh and shouldn't have any issues with it dropping.

I'd love to hear that something is being done about this...

0 Likes
Reply
kingzope
Newbie

Verizon can we please be given some notification?  Some acknowledgement that you're aware of the issue and working to fix it?

0 Likes
Reply
kingzope
Newbie

FYI to Verizon,

Please see the following thread: http://forums.macrumors.com/showthread.php?p=15971654&posted=1#post15971654

This needs to be addressed.

0 Likes
Reply
Jwander
Newbie

I have the same problem in Buffalo! I actually turned LTE off - I get no data whatsoever when I'm on LTE. As soon as I'm out if LTE range and switch to 3G, everything works fine again!

0 Likes
Reply