Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Xoom 4G has no signal
jpecora2732
Member

Our company jumped on the Motorola Xoom when it was released, and made sure to get the Xoom in for the 4G upgrade.  We had our devices updated, and the 4G is enabled.  However, the signal is horrible.  I have an HTC Rezound that has full 4G signal, next to my Xoom which has almost no signal (and usually drops to 'No Internet Connection')

 

Does anyone have any ideas on what could be the issue, or are we stuck with these until we upgrade them to a different device?

 

Thanks.

Labels (1)
0 Likes
Re: Xoom 4G has no signal
Not applicable

Jpecora2732, welcome to the community. I regret to hear that you have such low signal on your Xoom and lose data often. Does this just happen in one location or everywhere you use the device? One thing I would suggest first is to reactivate the SIM by removing the SIM for a few seconds then re-inserting it. You can just slide out the SIM/SD card door and then re-insert. The device will reboot. 

 

Other things you can do include toggling Airplane mode and the Network Mode (Settings>Wireless & Networks>Mobile Networks>Network Mode) for the device to see if this helps improve signal. 

0 Likes
Re: Xoom 4G has no signal
techismylife
Novice

jpecora2732 wrote:

Our company jumped on the Motorola Xoom when it was released, and made sure to get the Xoom in for the 4G upgrade.  We had our devices updated, and the 4G is enabled.  However, the signal is horrible.  I have an HTC Rezound that has full 4G signal, next to my Xoom which has almost no signal (and usually drops to 'No Internet Connection')

 

Does anyone have any ideas on what could be the issue, or are we stuck with these until we upgrade them to a different device?

 

Thanks.


Try looking into a 4G LTE amplifer and either an Omni External Antenna or a Yagi Antenna if you have a direct line of site with the tower I would recommend the Yagi. 

 

3Gstore has an incredible BlackFriday deals going on this morning, I attached a link to the Amplifier which would help you with the 4G LTE Signal.  

 

http://3gstore.com/product/3343_wilson_electronics_801865.html

0 Likes
Re: Xoom 4G has no signal
jpecora2732
Member

We have 2 Xooms doing the exact same thing.  We have removed the LTE SIM card, rebooted the device in CDMA only mode and then changed it back to LTE/CDMA, and it has made no difference.  My Rezound has full signal sitting right next to it, so I don't think that the signal into our building is an issue.

 

0 Likes