IP Passthrough Mode Limiting Speed to 100Mbps - ARC-XCI55AX
jonwitte5g
Enthusiast - Level 1

I am using an ARC-XCI55AX with IP Passthrough. My speeds are limited to 100Mbps - 120Mbps when IP passthrough is enabled. 

Confirmed that my cables are capable of gigabit speeds.

Confirmed that the ethernet ports on the 5g gateway are set to Auto. (Also tried with both ports forced to 1000Mbps Full Duplex, Same Result)

Tried connecting to another router with IP passthrough and speeds were exactly the same.

If I disable IP passthrough and use the WIFI and Ethernet Ports on the 5G gateway, Speeds are 300-350Mbps.

I am connecting to the 5G gateway to Google Wifi Router while in IP passthrough mode. This router previously handled 600+Mbps connection from comcast without any issues. nothing on the router would limit the speed coming from the 5G gateway.

Has anyone else experienced an issue like this?

Re: IP Passthrough Mode Limiting Speed to 100Mbps - ARC-XCI55AX
Cang_Household
Community Leader
Community Leader

That is definitely weird. IP passthrough should take less CPU usage than not passthrough, i.e. NAT'ed, you should in fact see an increase in speed if the router was the bottleneck before enabling the passthrough (this is unlikely).

0 Likes
Re: IP Passthrough Mode Limiting Speed to 100Mbps - ARC-XCI55AX
madbrain
Newbie

I'm seeing the exact same problem. Just got an ARC-XCI55AX  a few hours ago. Clearly used, with bent pins on the power supply. At first I couldn't get Internet at all with it until I factory reset it.

After that, things worked OK. I could get up to 110 Mbps down / 12 Mbps up using either Wifi6 or gigabit Ethernet.

See https://www.speedtest.net/my-result/d/c19a6822-e2ef-46ae-af67-f0315c98e878

I use pfSense as my router, so in this case everything was going through double NAT.  I also have a VPN servers on the router so I can't use double NAT. pfSense needs a public IP.

I then turned on IP passthrough in the admin UI. Switched the Ethernet cable to the other port. I got Internet, but speedtest shows much slower speeds, around 30 Mbps / 12 up on Wifi (using my own Unifi APs) and 50 down / 12 up on Ethernet. The pfSense box is self-built and supports 10gig speeds. With Comcast it could do 1400 / 240 through the 2.5 Gbps port on the Comcast gateway, and up to 800 Mbps down / 240 Mbps up on Wifi through Unifi. So, my router or APs are definitely not the bottleneck here. It looks like something fishy is going on with IP passthrough mode in the ARC-XCI55AX.

https://www.speedtest.net/my-result/d/61079003-c5ae-400e-814b-a80bcfd2e457

I cannot use 30-50 Mbps speeds. Verizon has improved the speeds a lot since the last time I tried the service with a Verizon SIM 3 years ago. My phone got a 5G signal, but speedtest was at 1 kbps. Not Mbps. So that's a 30,000-50,000 fold improvement in speed. But still too slow for the size of my network, which has a triple digit number of IP devices and may exceed a /24 subnet some day.

So, it seems the Verizon 5G network speed is now good enough, but the gateway/modem is misbehaving  in IP passthrough mode. Is there another gateway model that doesn't have this bug with IP passthrough ?

Maybe I will try the Plus plan, but not sure if I will get the 300 Mbps speeds advertised, especially with this gateway issue.

0 Likes