Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
U620L won't install correctly on Windows 7..
jone3
Member

I'm going insane here trying to figure out why my U620L won't install correctly on one of my laptops. The issue I'm having is on a Dell Latitude E5440 64-bit Windows 7 laptop. I plug it in but I get a message saying the device did not install correctly. If I look in the device manager, it's listed under network adapters with a yellow triangle and exclamation mark in it. The device status reads "this device cannot start (code 10)" in the device manager. Here are a few things I've tried:

-tried uninstalling the adapter in the device manager and then restarting the computer. I've done this too many times to count.

-I tried updating the driver by locating the drivers locally and by using Windows update

-tried taking the rndismp6.sys and usb80236.sys drivers from another computer the Mifi worked on

-tried playing with the power settings to the usb ports

-tried using a windows run me now fix-it for solving usb hardware issues.

-wasted time calling Verizon and talking to a support staff member for over an hour who had no idea what she was talking about.

I'm at a complete loss. Any insight or help would appreciated.

Labels (1)
Tags (1)
0 Likes
1 Solution

Correct Answers
Re: U620L won't install correctly on Windows 7..
jone3
Member

Thank you for your advice. I actually was just able to fix the problem. This particular laptop was using an Intel 8 series chipset which was known to have difficulties with its host controller and communicating via the two USB 3.0 ports on the sides of the laptop. Intel released a new host controller driver a couple of weeks ago. I installed the driver today and voila the modem works on the USB 2.0 port as well as the two 3.0 ports.

View solution in original post

Re: U620L won't install correctly on Windows 7..
John_Getzke
Leader
Leader

> this device cannot start (code 10)

This is a classic hardware error message.  Most of the time in my experience the only solution was to either reboot the PC or swap out the hardware in question as defective.  From the PCs perspective there isn't much you can do to a device that isn't powered on correctly.  The PC knows something is there but it cannot communicate with it.

It looks like you have already tried everything that I would have suggested for a software fix.  The only other step is to test with a few other machines and then contact VZW for replacement options as a hardware failure.  If the device cannot power up correctly on multiple machines it should be a simple call to swap it out for new hardware.  VZW would let you know what options you have for warranty, upgrade or new purchases accordingly.

0 Likes
Re: U620L won't install correctly on Windows 7..
jone3
Member

Thank you for your advice. I actually was just able to fix the problem. This particular laptop was using an Intel 8 series chipset which was known to have difficulties with its host controller and communicating via the two USB 3.0 ports on the sides of the laptop. Intel released a new host controller driver a couple of weeks ago. I installed the driver today and voila the modem works on the USB 2.0 port as well as the two 3.0 ports.

View solution in original post

Re: U620L won't install correctly on Windows 7..
John_Getzke
Leader
Leader

Excellent, thanks for the confirmation and sharing your solution.

0 Likes