Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Corporate Sync on Droid 3 will not connect to my exchange server
hambletw
Member

My previous phone (droid x with 2.3.3) connected to exchange.  new droid 3 (with version 2.3.4) will not connect to exchange. anyone know if a fix is in the works?

Tags (2)
0 Likes
1 Solution

Correct Answers
Re: Corporate Sync on Droid 3 will not connect to my exchange server
Shark_PC
Member

Hello!

 

Your problem is perhaps is being caused by your Exchanges SSL certificate being "self-signed".  Droid version 2.3.4 does not play nice with email servers that do not have third party certificates installed and if your Excvhange server is Exchange 2010 then this will be especially true. I had this problem with my phone and if spilled over into issues connecting not just with ActiveSync but with IMAP and POP regarding the Exchange server in question. I run my own Exchange so I went ahead and purchased a third party cert, installed it and all was well.  I wrote a shor blog about it here: http://sharkpc.blogspot.com/2011/08/fyi-microsoft-exchange-activesync-imap.html

 

If you are not in control administrativly of your messaging environment then I would say that your only current work around would be to use an app like "Touchdown". You can get it free in the Android market for a 30 day trial and then you would have to pay after that. It has a pretty decent feel to it. However If in a corporate environment, the 3rd party SSL is the way to go!  Hope this helps and enjoy your Droid 3!     

View solution in original post

0 Likes
Re: Corporate Sync on Droid 3 will not connect to my exchange server
AyaniB_VZW
Verizon Employee

Hi hambletw,

 

 

I apologize for the delayed reply and understand the importance of receiving emails. I hope your issue has been addressed in the interim.  We are aware of this issues and awaiting a software update from the manufacturer.  As a work around try adding a gmail account to setup a corporate sync and then modify that with the actual credentials by disabling certificate checks.  I hope this information is helpful.  Please let me know if you require additional assistance.

 

 

 

Thank you for you involvement in our community forums,

0 Likes
Re: Corporate Sync on Droid 3 will not connect to my exchange server
singleflow
Member

Do we have any more information regarding this update? This is kind of a big deal. I'm surprised more people aren't complaining about this on here.

0 Likes
Re: Corporate Sync on Droid 3 will not connect to my exchange server
sjuver
Member

Adding my two cents to the complaints, same problem.  I am on a Droid 2.  People all over the net are complaining about this.

 

Is there any way to go back to the previous version of the OS?

0 Likes
Re: Corporate Sync on Droid 3 will not connect to my exchange server
Shark_PC
Member

Hello!

 

Your problem is perhaps is being caused by your Exchanges SSL certificate being "self-signed".  Droid version 2.3.4 does not play nice with email servers that do not have third party certificates installed and if your Excvhange server is Exchange 2010 then this will be especially true. I had this problem with my phone and if spilled over into issues connecting not just with ActiveSync but with IMAP and POP regarding the Exchange server in question. I run my own Exchange so I went ahead and purchased a third party cert, installed it and all was well.  I wrote a shor blog about it here: http://sharkpc.blogspot.com/2011/08/fyi-microsoft-exchange-activesync-imap.html

 

If you are not in control administrativly of your messaging environment then I would say that your only current work around would be to use an app like "Touchdown". You can get it free in the Android market for a 30 day trial and then you would have to pay after that. It has a pretty decent feel to it. However If in a corporate environment, the 3rd party SSL is the way to go!  Hope this helps and enjoy your Droid 3!     

View solution in original post

0 Likes
Re: Corporate Sync on Droid 3 will not connect to my exchange server
r1507918
Member

Found solution to setting up Corporate Sync email on Droid 3 connecting to Exchange Server

 

Create or edit an existing gmail account.  Use user@gmail.com for user name and m.google.com for server name. Once this works edit email account settings:

 

For user name put in your fully qualified corporate user name.

 

For email address use actual corporate email address.

 

Password is your corporate domain password.

Here's the catch!!  for Account name enter your exchange domain name.

Uncheck "use secure connection" hit next and it should connect to the mail server.

0 Likes
Re: Corporate Sync on Droid 3 will not connect to my exchange server
Zephyrist
Member

Funny how this is now marked "solved" when to me it looks like a work-around at best.  A few months into launch and there's still no fix other than the 2 above workaround solutions.

 

I guess this means it cant be fixed.  Thanks Verizon and Motorola for once again launching a product that wasnt ready.

0 Likes
Re: Corporate Sync on Droid 3 will not connect to my exchange server
nomad1229
Member

I work for one of the largest equipment manufacturers in the world which in turn I am hired out to the carriers for consulting work. I change projects quite often and have never had to use the "coporate sync" to set up my mail on my droid on an exchange server. It's a very simple procedure just using the email accounts. You just have to know your incoming and outgoing and wham.....it's done. Screw the corporate sync and just set up another email account as long as it's on an exchange server

0 Likes