Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Fascinate (How very Sad)
Larryw54
Member

So you know I was all excited about the Fascinate. Reviews were good and all that, Went to Verizon store (Back in Winter of 2010) and the sales people all promised that the update would come. Why did I need to know this? Because I told my family for Christmas to get me the desk cradle and the car cradle because I could plug in my speakers into it when 2.2 came out.

We are now into March of 2011, Everyone wants to know why I can not use the gifts that were bought for me?

Do I tell them the truth that Verizon, well, didn't quite tell me the truth!

Do I dare ask for a new Phone for my B-Day (March) or do I ask for a refund so I can give my family there money back for a product I can not use?

Do I cancel all of my phones from Verizon (4 x phones) and go with someone who actually has the {word filter avoidance}
to tell us the truth. (It will set you free)

Or will they continue to hide like most of corporate America when they are caught with there jaw hanging on the ground.

I know that I for one will have to really think about upgrading and continuing with Verizon. And you know what Verizon, I do not mind spending some extra money in order to "get what I paid for" Good or Bad tell me the truth. That is all I ask and all the rest of YOUR PAYING customers wants, the truth.

If you are coming out with Gingerbread 2.3 tell us. I will consider staying unless this is another UN-truth. It's up to you.

Me and my 200.00 per month will not wait much longer.

All in agreement say aye!

0 Likes
Re: Fascinate (How very Sad)
Squallfyr
Novice
Nay, and I do beieve you're posting in the wrong category. this will most likely be moved.
0 Likes
Re: Fascinate (How very Sad)
AZSALUKI
Sr. Leader
Sr. Leader
There's an easy way for you to get 2.2 but you can't discuss here. Google it or try other forums.....but you can get 2.2. Also, take it up with Samsung, not Verizon. NONE of their galaxy s line of devices has 2.2.....no matter which carrier you try.
0 Likes
Re: Fascinate (How very Sad)
Wildman
Sr. Leader
Sr. Leader

I feel your pain but I have to point out that one of the golden rules I have on technology, I never buy a device for what it is suppose to due or get in the future, technology come and go so fast that you really can determine the shelf life.

 

Now as for you using the accessories that your family bought you, why do you have to wait for update to use them because they should work now with stock os or they would be having the product for sale?

0 Likes
Re: Fascinate (How very Sad)
AZSALUKI
Sr. Leader
Sr. Leader

yeah...i also don't quite understand why a dock wouldn't work due to the OS????

0 Likes
Re: Fascinate (How very Sad)
Larryw54
Member

Thanks for the reply all. The accessories will not work with 2.1, and it says it right on the devices. Of course being who I am, I tried to connect speakers to the dock and it is true, it does NOT work.

0 Likes
Re: Fascinate (How very Sad)
Wildman
Sr. Leader
Sr. Leader

May I ask the model number of the dock because I have never heard or this issue, and this really makes no since for them to sell the accessory because the Fascinate was released with 2.1 and there wasnt no official report of when the device would get 2.2 so I dont get how a accessory made for a device released with 2.1 doesnt support 2.1.....  This seems to make no since what so ever.

 

Please share the model number of dock because I would like to research this further...

0 Likes
Re: Fascinate (How very Sad)
Ann154
Expert
Expert
0 Likes
Re: Fascinate (How very Sad)
AZSALUKI
Sr. Leader
Sr. Leader

i'm with you wildman. i just don't see how an OS would prevent a speaker from plugging in and working???? i'd like to see the models as well because if this is the case, then i've got some learnin to do before buying docks and other accessories. 

0 Likes
Re: Fascinate (How very Sad)
Wildman
Sr. Leader
Sr. Leader

Thanks for the links but I am still confused because according to the sites it is compatible with the Fascinate and does not have any special restrictions...

 

3-10-2011 10-06-37 PM.png

 

3-10-2011 10-07-02 PM.png

0 Likes