Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
***Announcement: We’re excited to inform you that we will be merging the Fios and Wireless Communities to a unified Verizon Community with a new look and feel throughout. If you are interested in what specifically has changed, please see the New Revamped Community article under the Featured Topics.***
Maps app & Navigation not working. Any tips?
S2D2
Member

Last night Maps quit working on my Motorola Droid.


When I select the Maps or Navigation options all I get is:

Sorry!

The application Maps (process.com.google.android.apps.maps) has stopped unexpectedly. please try again

| Force Close |

 

I've tried rebooting it several times, removed the battery & restarted once, checked the application settings menus but have not had any luck getting it to work.

Has anyone else had this problem yet or know of a  way to reboot the map app? 

0 Likes
Re: Maps app & Navigation not working. Any tips?
Packet
Member

Have you installed any third party apps that might hook into the maps system?  If so, they might be trying to modify the Android 1.5 or 1.6 version of Maps, and crashing things horribly because the Android 2.0 maps application is (to put things mildly) rather different.

0 Likes
Re: Maps app & Navigation not working. Any tips?
ashademolly
Member

I had the same problem yesterday.  I had to drop by a Verizon store today to get a different screen protector anyway (touch doesn't work with the privacy screen) so I asked them to look at it.  They hadn't heard of the issue before, but after a little while one of the techs managed to figure out that it has something to do with the data in the cache for the maps app.

 

Here's how to fix it:

 

+From the Home screen, click on the menu button.  

+Then click 'Settings'.  

+Click on 'Applications'.  

+Then click on 'Manage Applications'.  That should default to showing you all of the apps you've downloaded so far.  

+Now press the menu button again and it brings up two options.  

+Click on 'Filter'.  

+Then choose to filter 'All'.  Now you can see everything that's installed on your Droid, including pre-installed apps.  

+Scroll down and click on 'Maps'.  You should see buttons labeled 'Clear Data' and 'Clear Cache' as well as some others.  

+You're going to want to click on 'Clear Cache'.  

+Then just tap the Home button and try to load up Maps again.  

 

There you go!  Problem solved.

0 Likes
Re: Maps app & Navigation not working. Any tips?
Mondo
Member

Thanks for the tip.  This worked for me, except that I cleared the map app's data, not cache (cache was 0). 

 

Note that other forums (fora?) have suggested that downloading the power app (5 icons across) causes the problem.  That fits for me.

0 Likes
Re: Maps app & Navigation not working. Any tips?
bobwhitlow
Member

clear cache is grayed out. Only option is to clear data

0 Likes