Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
What happened to Tetris?
Ludist210
Member

So I had to reload my Droid X, and every purchased app that I bought loaded just fine...except for Tetris by EA Mobile.

 

I noticed that between Christmas and Valentine's Day, EA Mobile cleared all of their Market apps on Verizon and put them back out there.  Same versions and everything, but Tetris did not appear as installed for me.  Apparently this is because of Verizon's "V-Cast" apps or some kind of exclusivity deal.

 

Regardless, this was an app that both I and my wife paid $4.99 for at the time, and now we can't get updates or re-download in the event of some kind of disaster with out phones.  If we had been informed of this prior to it happening, that would be one thing.  And yeah, it's just one game, but I really liked wasting time with Tetris.

 

Also to note: I've contacted both EA Mobile (actually got an answer) and Google, and they're pointing their fingers at Verizon.

0 Likes
Re: What happened to Tetris?
gerio
Sr. Member

This happened to me when I retored the phone a month or so ago (or something like that). I kept looking for it to show "purchased" and for a while, it was listed as "purchased", but when I tried to re-install it, it just said "can't be found". 

 

At the time, I had bigger things to worry about than a $5 game I love to play, but hardly have the time, so I forgot about it for a couple of weeks. After that., I was looking through my instaleld apps, saw Tetris in the "purchased" list and tried to download it. And this time, it downloaded and installed with no problems. 

 

So keep trying, maybe it will finally work for you.

 

Good luck, 

Geri O

0 Likes