Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring your phone. Plus, get the incredible iPhone 13 Pro on us. Online only. With select 5G Unlimited plans. Ends 12.5. Buy now
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
***Announcement: Early next week, we’ll be merging the current Fios and Wireless Communities into the all new Verizon Community! Beginning the evening of Sunday 12/4, both Communities will be placed in read-only mode. You’ll still be able to visit the Communities and browse content, but login will be disabled. On the afternoon of Monday 12/5, all users will be able to log into the new Verizon Community. We expect the new Community to be fully functional the morning of Friday 12/9. Additional details can be found in the Announcements board and under Featured Topics!
Avoid bad wifi connections not working?
TONY_W
Member

I have an LG G6 running Oreo 8.0.0. I'm trying to get it to stop switching from wifi to the mobile network, but the "Avoid bad Wi-Fi connections" switch doesn't seem to be working. Whether I turn it on or off, the phone keeps switching back to the mobile network, apparently when the wifi signal gets a little weak. If I'm not paying attention when it switches, I can really eat up a lot of mobile data. Any ideas on how to force it to stay connected to the wifi?

Labels (1)
0 Likes
Re: Avoid bad wifi connections not working?
dexman
Sr. Member

My Samsung Galaxy S7 Edge has the ability to disable 4G/LTE. This forces everything over to WiFi.

On the S7, I swipe down twice and deactivate the item labeled "Mobile Data". This switches off 4G/LTE.  By only activating 4G on an as needed basis, most of my 1Gig/month allotment is untouched.  

0 Likes
Re: Avoid bad wifi connections not working?
bearone21
Leader

are you moving or stationary??  what's the difference between good/bad wi-fi??

0 Likes
Re: Avoid bad wifi connections not working?
TONY_W
Member

I would rather not have to resort to turning mobile data on/off like that. I would rather have the network switching setting work like it's supposed to.

I'm not even sure why the phone is disconnecting from wifi. This is when I'm home and the signal is almost always fine. Other devices don't have this problem. It could be a problem with my phone's wifi, but that doesn't explain why the "Avoid bad Wi-Fi connections" setting isn't working. When that setting is turned off, the phone is not supposed to switch to the mobile network even if the wifi signal is bad, right? I mean, that's kind of the whole point of that setting.

0 Likes
Re: Avoid bad wifi connections not working?
dexman
Sr. Member

The S7 Edge doesn't appear to have the bad Wifi feature, so, I have seen it in action. If the phone is the only device that can't hold a reliable connection to the Wifi unit, and, the signal is strong, some options would be to delete and re-add the Wifi to the phone, reset the Wifi unit and/or do a factory default of the phone.

Turning 4G/LTE off & on may be a pain, but, it does the trick. As a test, consider trying it for one hour or even one night to see how the phone reacts.  

0 Likes
Re: Avoid bad wifi connections not working?
dexman
Sr. Member

The only times I can recall my old SGS4 and my S7E dropping a strong Wifi signal was when I had the screen brightness cranked up high and the phones heated up. The internal heat caused the phones to drop & either switch Wifi spots or drop & reconnect.

0 Likes
Re: Avoid bad wifi connections not working?
TONY_W
Member

Oh, I know turning off mobile data works. When I do that I can sometimes see the phone disconnecting from the wifi and then reconnecting. The reconnect usually happens almost immediately. But when mobile data is turned on, the phone seems to be immediately connecting to the mobile network when the wifi connection drops, instead of trying to reconnect to wifi. I thought this was what the "Avoid bad Wi-Fi connection" setting was supposed to prevent, but it's not working.

0 Likes
Re: Avoid bad wifi connections not working?
dexman
Sr. Member

Could it be a heat issue? As long as the S7 Edge's internal temperature in check, Wifi stays locked. Once the internal temperature goes up, the phone, eventually starts dropping/switching. Bring the temperature down and everything goes back to normal. ☺️

0 Likes
Re: Avoid bad wifi connections not working?
TONY_W
Member

This isn't so much about the phone dropping wifi. Yes, there could be a problem with it (and it could be heat related, as you suggest). But what I'm really trying to figure out is why the "Avoid bad Wi-Fi connection" setting isn't working. Regardless of what's causing the wifi disconnections, that setting isn't forcing a reconnect like it should.

0 Likes
Re: Avoid bad wifi connections not working?
vzw_customer_support
Customer Support

Thanks for reaching out to us with your concerns, TONY_W. We want to make sure you get the help you need to be able to enjoy your device as much as possible.

The first thing you need to do in this case is  to check the Wi-Fi sleep policy setting of the phone and make sure that the Wi-Fi stays on even when the screen is off.

  • Swipe down from the top of the screen
  • Tap and hold on the Wi-Fi icon
  • Tap the Menu icon
  • Tap Advanced Wi-Fi
  • Tap Keep Wi-Fi on when screen is off
  • Tap your desired sleep policy

If the issue persists, we need to look into other options. Please let me know if this information is helpful.

0 Likes