Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
HTC quick charge no longer working
Angeliize2
Member

I have had my HTC 10 since June.  It charged beautifully and held a charge longer than any phone I have had.  Starting 2 days ago it started to take longer to charge.  Tonight I placed it on the quick charge at 56%.  4 hours later without being used while charging it is at 85%.  I do not leave it on the charger after it is fully charged.  I usually wait a little long to place it on the charger but I was hoping to get it to 100% before I went to bed.  I won't leave it plugged in over night and I use it for music to sleep to and an alarm.  It has gone from the quickest charger ever to the slowest.  Anyone else experiencing this and any suggestions?

Labels (1)
0 Likes
Re: HTC quick charge no longer working
stever_vzw
Verizon Employee

Angeliize2, we certainly want to take a closer look at the phone and make sense of what has caused this change. We appreciate all of the details and I would be happy to continue helping.

We do recommend that you run a diagnostic View Device Health Check - MVD - Android | Verizon Wireless  on the phone when you have the opportunity. Has the phone suffered any physical or liquid damage? Are you utilizing the charges that was with the phone originally? Please provide a few additional details and we will be ready to continue helping.

SteveR_VZW

Follow us on TWITTER @VZWSupport

If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: HTC quick charge no longer working
Angeliize2
Member

I will run the diagnostic this week but I wanted to answer you other questions.  Yes- I am using the original charger and cable.  I have learned from a past bad experience not to use 3rd party chargers.  No, there has not been any physical or liquid damage.

I will get back to you after I run the diagnostic.  Thank you for your response.

0 Likes