Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Incoming calls on Droid Z start with + Sign
TOHUSKER
Member

How do I stop my incoming calls from having a plus sign? My number doesn't show up on my caller ID in the car. I have downloaded prefixer and that doesn't work and I have also looked at the dialer and it shows USA in Assisted dialing status and its currently off. Any help would be appreciated.

Labels (1)
0 Likes
Re: Incoming calls on Droid Z start with + Sign
Ann154
Expert
Expert

You probably have to turn off the HD Voice feature on your line and phone to stop the +1 numbers from showing. It is part of that feature that they are being displayed that way.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.