Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Showing number on incoming calls
R_A
Member

A couple weeks ago I upgraded from Droid Turbo to Moto Z3.  On my new phone, when a phone call comes in it does not show the number for non-contacts.  I've fiddled with the settings as much as possible with no success.  How can I get incoming calls to show when they arent a known contact?

Labels (1)
0 Likes
Re: Showing number on incoming calls
vzw_customer_support
Customer Support

R_A, congratulations on your new phone. When getting a new device we know that it is crucial to enjoy the features that you have come to rely on. When you receive an incoming call from someone that is not a contact, what exactly is displayed? Does this happen with every call not listed or specific ones?

Loren_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: Showing number on incoming calls
bearone21
Leader

Settings > Apps > App Info > Phone > App Notifications.  Make sure it's green, and incoming calls is green and choose setting make sound and pop on screen

0 Likes
Re: Showing number on incoming calls
TAZ8680
Member

I have the same issue. It's with every call not in contacts. The only thing that displays is "Unknown Caller" and the phone number will not display.

0 Likes
Re: Showing number on incoming calls
vzw_customer_support
Customer Support

TAZ8680,

 

 

Help has arrived! We want to make sure that you can see a phone number display when a call comes through from a non-contact number. Allow me to start by collecting some pieces to this puzzle. What make & model phone do you have? When did this problem start or should I ask, have you had this problem ever since you have had your phone? Do you by chance have the SmartFamily feature on your line with any controls that may be blocking numbers?

 

 

Alicia_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: Showing number on incoming calls
Kreineh
Member

I have the same problem. I use my phone for work and can tell more from the number than I can some vague "potential spam" or other "unknown number" label. I want to see the phone number. I have a Moto Z. This last update doesn't show phone numbers anymore. This isn't the only problem I've had with the latest update. The other one I won't even go into, it just has to do with email and I could suffer with it but if I can't fix this, so long Android, I'm done with you.

0 Likes
Re: Showing number on incoming calls
TAZ8680
Member

I called tech support today. Do you have the Verizon Caller ID app? I unsubscribed and now can see the phone number instead of just UNKNOWN CALLER.  Hope that helps

0 Likes
Re: Showing number on incoming calls
vzw_customer_support
Customer Support

We understand your concern regarding this. This does not happen with your saved contacts correct?

LauraL_VZW
Follow us on Twitter @VZWSupport
If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!

0 Likes
Re: Showing number on incoming calls
WinterDisco
Member

I had this problem on the Moto G7 Power. going into settings>apps&notifications>see all apps then finding Call Filter, force closing and disabling fixed this issue.

0 Likes