Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
***Announcement: We’re excited to inform you that we will be merging the Fios and Wireless Communities to a unified Verizon Community with a new look and feel throughout. If you are interested in what specifically has changed, please see the New Revamped Community article under the Featured Topics.***
"Unable to activate Wi-Fi Calling at this time. Please try again later."
Deepchampagne
Member

No matter what I try, I'm unable to activate Wi-Fi calling on my Samsung Galaxy S8.  I'm going to setting -> Connections -> Advanced Calling -> Activate WiFi Calling. This is frustrating because I live in an area with poor cell service.

Here's what I've done so far to trouble shoot:

  • Restart the phone
  • Clear the phone cache
  • Enable all Verizon default apps
  • Confirmed HD Voice and Video calling is ON.

After all of these, I still just get a message, "Unable to activate Wi-Fi Calling at this time. Please try again later," when trying to activate. Please help.

Labels (1)
Tags (1)
1 Solution

Correct Answers
Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
Corndawg
Member

So I tried most of the above steps, then I thought, maybe I just need to turn wi-fi off and then try setting it up. That did the trick! Just turn wi-fi off and try to verify your emergency contact information. This worked for me. 

View solution in original post

Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
jav6
Leader

Where is your WiFi signal coming from?

...Just another VZW customer...trying to offer some assistance...
0 Likes
Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
vzw_customer_support
Customer Support

I'm sorry to learn that you are unable to activate WiFi Calling, Deepchampagne. We are committed to resolving this issue for you.

 

Have you ever been able to use the WiFi Calling feature at the trouble location?
Are you able to use the WiFi Calling feature in other locations?
What is the ZIP code for the trouble location? I would like to take a look at coverage in that area.

 

 

Antonio_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
KEVVAR3
Member

ANSWER:

Settings > Apps > Show System Apps > View: Disabled >> Enable "My Verizon Services"

Make sure HD Voice and Video Calling is on.

Wi-Fi calling does NOT work on unlocked phones. The phone needs to be a Verizon model.

Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
boringusername
Sr. Member

KEVVAR3 wrote:

ANSWER:

Settings > Apps > Show System Apps > View: Disabled >> Enable "My Verizon Services"

Make sure HD Voice and Video Calling is on.

Wi-Fi calling does NOT work on unlocked phones. The phone needs to be a Verizon model.

On MOST unlocked phones

0 Likes
Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
Hallac
Member

Had the same issue following June 6, 2019 update.

Went into Apps/View System Apps/My Verizon Services app, then go into Permissions and enable all of them. That forced the phone to finally prompt me to enable Wifi Calling and that fixed everything. 

Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
Allriz
Member

This didn't work for me, very annoying. Started after the June 6, 2019  update.

0 Likes
Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
Ted75zcar
Member

Same boat, Galaxy S8+

0 Likes
Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
Ted75zcar
Member

I was able to get it to work, you have to enable all of the Verizon Services permissions, then Restart the device.

0 Likes
Re: "Unable to activate Wi-Fi Calling at this time. Please try again later."
Cd777
Member

I've tried everything suggested in this thread and it still won't work... I just want to get rid of that dang notification at this point!!