Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
why can't I install and use pokemon go
Poppoplew
Member

why can't I install and use pokemon go

Labels (1)
0 Likes
1 Solution

Correct Answers
Re: why can't I install and use pokemon go
Ann154
MVP MVP
MVP

Screenshot_20160905-170155.pngScreenshot_20160905-170213.png

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

View solution in original post

Re: why can't I install and use pokemon go
Ann154
MVP MVP
MVP

Which phone model do you have? Is it compatible with the application?

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Re: why can't I install and use pokemon go
Poppoplew
Member

Hi, thanks for responding ! I have a Samsung galaxy s3 phone with android 2.2 and 16 GB of storage. I have a no contract plan with Verizon for $45/month. When I go to the google play store, it says this app is incompatible with my device yet according to what I read on the internet others with the same phone are ok. A Verizon employee at best buy told me that it's probably because I have a no contract phone and Verizon won't allow it.

0 Likes
Re: why can't I install and use pokemon go
pherson
Leader

I'm hanging up my technology and moving. why can't I install Pokemon go? I'm too thru

0 Likes
Re: why can't I install and use pokemon go
Ann154
MVP MVP
MVP

Did you look at the application description from the Play Store website on a computer or another device's browser and not through the Play Store app? Pokémon GO - Android Apps on Google Play  It clearly indicates that the device needs to have Android 4.4 and higher plus be one of the devices the Developer marked as a compatible device. From what you have provided, your device isn't compatible with the application. For example, my tablet while running an OS version that is higher than the minimum it isn't compatible with the application either.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

Re: why can't I install and use pokemon go
Ann154
MVP MVP
MVP

Screenshot_20160905-170155.pngScreenshot_20160905-170213.png

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

Re: why can't I install and use pokemon go
bearone21
Leader

2.2????, my old s3 ended up at 4.3......might be why other apps don't work properly.

0 Likes
Re: why can't I install and use pokemon go
Ann154
MVP MVP
MVP

Even at Android 4.3, it doesn't appear to be compatible with the that application.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

Re: why can't I install and use pokemon go
Acrillix
Sr. Member

BTW those reps at bestbuy at the VZW booths are indirect agents. They probably work for Cellular Sales or another authorized retailer

0 Likes
Re: why can't I install and use pokemon go
vzw_customer_support
Customer Support

We want you to be able to use this popular application, Poppoplew. Our community members are providing some great tips. After checking some resources, we found that the prepaid version of the Galaxy S III did receive Android 4.4 on August 21, 2014. When you go to Settings > About Phone > Software Update, do you see an available update?


LynnD_VZW
Follow us on Twitter @VZWSupport
If my response answered your question please click the �Correct Answer� button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes