Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Just got CPO iPhone 4s with wifi connection issues!!!
Staysha719
Member

Got the phone yesterday. (Prepaid certified preowned.) Tried to put in the wifi password, which the phone rejected as incorrect. Activated it over iTunes. I called to have my existing number assigned to the new phone and I tried asking about this, but the guy I was talking to didn't understand. (Language barrier maybe. Idk. He told me to turn off wifi to use 3G so I gave up.) Knowing this is a well known iOS issue, I updated to 8.3 for the possible fix. Still not connecting UNLESS it's next to the router. I did get it to connect that way but lost the connection once I moved away from the router. My droid tablet and computer consistently stay connected. My old iPhone 4 (which I was replacing) connects but the speaker is broken and I can't hear calls. (It drops frequently, but reconnects eventually.)

After doing a ton of research I've discovered that this is really not uncommon. I've tried resetting the network, updating router firmware, checking and changing wifi settings on the router, resetting the router, almost every suggestion I've read but nothing has worked. I'm not putting it in the freezer. I'm very worried that if I send it back for another one, I'll have the same exact issue. Is it even worth trying to do a factory reset, since it came to me with this problem, or am I stuck either sending it back or having no wifi?

Labels (1)
0 Likes
Re: Just got CPO iPhone 4s with wifi connection issues!!!
vzw_customer_support
Customer Support
Staysha719,

Being able to use all the functions on your phone is definitely important, so I understand how you feel. I see you've done some great troubleshooting already. Let's get to the bottom of this and get your phone working right.

Is the issue with all wifi connections or just a certain one?

JohnB_VZW
Follow us on Twitter @VZWSupport

If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!
0 Likes
Re: Just got CPO iPhone 4s with wifi connection issues!!!
dwt12777
Member

Hi, I don't mean to hijack this thread, but the original poster didn't reply and I'm having the EXACT same issue: a few days ago my wife was sent a replacement iPhone 4S (after visiting the Verizon store to report failure to charge problems).  The replacement works great except the wifi... when I try to connect it to our home network, it keeps acting like I'm entering the wrong password.  However I've double-checked now dozens of times, and I have multiple other devices connecting to the same SSID and confirmed I'm using the same WIFI password on those other devices, and they all work fine, which would make me think the problem is specific to the phone.

However, to complicate matters, I HAVE been able to successfully connect the phone to another WIFI network as a test.  So it's not a simple black and white "wifi doesn't work" scenario, but rather "the wifi that matters doesn't work."

I've wiped and reloaded the phone from iTunes twice, reset network settings, reset all settings, but no luck so far.  Ideas?

0 Likes
Re: Just got CPO iPhone 4s with wifi connection issues!!!
vzw_customer_support
Customer Support

@dwt12777


You're not hijacking the thread! (Smile)  We're here to help.


Do you get an error message when trying to connect to your home WiFi network?  If so, what is the exact error message?  Also, what is the current software version of your iPhone 4s: http://vz.to/1AYAigf?


AnthonyTa_VZW

Follow us on Twitter @VZWSupport


If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: Just got CPO iPhone 4s with wifi connection issues!!!
dwt12777
Member

The error message when I try to connect to the wifi network is:

[header] Failed to join "atlas2"

[window] Incorrect password for "atlas2" [button: Dismiss]

Also, I should mention that when I plugged the phone in to iTunes this evening it offered to upgrade my phone from iOS 8.3 to 8.4, which, after running for a while (downloading, extracting, backing up...), failed with:

The iPhone "iPhone" could not be updated. An unknown error occurred (3014).  [button: OK] [button: More Information]

Clicking "More Information" took me to: https://support.apple.com/en-us/HT201442

But then the phone itself prompted me (independent of iTunes) to install 8.4, which I accepted.  That seemed to work (phone rebooted, apple logo/progress bar for several minutes, etc.) until it finished.  iTunes then recognized the phone as having 8.4 installed.

However, after all that was done, I retried the wifi network and the original problem persists: I still cannot establish a wifi connection from this phone to my home network.

0 Likes
Re: Just got CPO iPhone 4s with wifi connection issues!!!
vzw_customer_support
Customer Support
dwt12777, we appreciate all the troubleshooting you have performed thus far. Happy to see you were able to get your iPhone updated. Regarding WiFi connectivity, does your iPhone connect to it if you remove the password encryption?

Not sure if you have tried this, but have you attempted changing the frequency range and encryption your router is broadcasting as well, just to test?


For example if it is set up as WPA -2, switch to just WPA-TKIP


Or if you are broadcasting in a mixed B,G,N network, try reducing it to just N, or B,G.


Sometimes even swapping the Channel range from auto or the default Ch.6 can help. Try maybe 1 or 11 if available.


Please keep us posted!



NicandroN_VZW Follow us on Twitter @VZWSupport If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: Just got CPO iPhone 4s with wifi connection issues!!!
dwt12777
Member

I appreciate the help troubleshooting this.  So far, no luck.  After each of the following steps I stopped and attempted to connect the iphone 4s to the network.  I also connected my Galaxy S3 to the same network after each step.  In each case, the Galaxy s3 would successfully connect to the network and the iphone 4s would not.  The result is still the same: after prompting me to enter the password for the network, the phone reports "failed to connect to [network]" or "incorrect password for [network]."  Here is what I've done:

  1. Changed security from WPA2 AES to WPA2 TKIP
  2. Changed security from WPA2 TKIP to Disabled (no security, no password)
  3. Renamed SSID to a different name
  4. Disconnect all other devices from router
  5. Changed broadcast band from mixed (B, G, N) to N only
  6. Changed broadcast channel from 6 to 1

Not sure where to go from here.  The previous iPhone 4s which was just replaced by this one had no wifi connection problems.  And our other devices in the home (rokus, galaxy s3, computers, tablets) all connect fine to the same router I'm trying to use.

0 Likes
Re: Just got CPO iPhone 4s with wifi connection issues!!!
vzw_customer_support
Customer Support

Thanks for performing all those trouble-shooting step dwt12777. I'm sorry you're still having issues with wifi on your replacement phone. The last step is a Factory reset. Here are the steps and make sure your data is backed up before performing this step http://vz.to/1HTxLM5 . Keep us posted.


KinquanaH_VZW Follow us on Twitter @VZWSupport If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: Just got CPO iPhone 4s with wifi connection issues!!!
dwt12777
Member

Before doing the factor reset as you suggested, I tried something else:

All my testing thus far has been at a desk about 15 feet away from the wifi router in the same room, no walls/obstructions in the way.  And other devices that have been connecting to this router can do so from the other side of the house (through walls, corners and children).  But on a whim, I put the iphone right next to the router (within 2 feet) and tried again.  This time it successfully accepted my password and let me use wifi functionality.  (Remember before, 15 feet away, it would see the SSID but not accept my password).  With it now connected, I returned to my desk to see if it would hold the connection from 15 feet way.  It did not.  It would no longer browse the web or do anything else over wifi.  Then, when I disconnected and tried to reconnect, it would fail.

It was behaving as if it has an extremely week wifi antenna.

So I proceeded with the factory reset you suggested.  I had to do so 4 times - kept getting errors halfway through and was worried I'd bricked my phone, but one of the errors said something about connectivity so I swapped out the cable and it was able to finish the reset/restore.

However the wifi issue persists - still extremely week.  I can connect if I'm right next to the router, but otherwise it fails.

0 Likes