Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
No iMessages
kkhabir
Member

My iPhone X hasn't been receiving iMessages for the last 2 days unless connected to Wifi. Anyone know what is causing this?

Labels (1)
0 Likes
1 Solution

Correct Answers
Re: No iMessages
kkhabir
Member

Got it fixed.

Turning iMessaging off and on didn’t work, and neither did restarting the phone. To fix it I did the following.

Settings > Messages > send and receive > uncheck email address.

Then settings > messages > turn off iMessage

Then then off phone and turn back on.

Then wait a couple minutes and turn imessaging and messaging via email back on.

What a pain. Easy enough to fix but obnoxious to not have working.

View solution in original post

0 Likes
Re: No iMessages
bd94s10
Sr. Member

Try this:

Settings > Messages > Toggle iMessage off and back on. I've seen this trigger something on Apple's server to resolve issues like this before.

If this doesn't work I'd contact Apple. The only other thing that I know will impact iMessage is having the time set on your device to automatic

Settings > General > Date & Time > ensure set to automatic.

0 Likes
Re: No iMessages
kkhabir
Member

Got it fixed.

Turning iMessaging off and on didn’t work, and neither did restarting the phone. To fix it I did the following.

Settings > Messages > send and receive > uncheck email address.

Then settings > messages > turn off iMessage

Then then off phone and turn back on.

Then wait a couple minutes and turn imessaging and messaging via email back on.

What a pain. Easy enough to fix but obnoxious to not have working.

View solution in original post

0 Likes
Re: No iMessages
bd94s10
Sr. Member

Thanks for sharing what worked! When it works it is generally flawless. When it doesn't it can be a tad annoying. Smiley Happy

0 Likes