Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
iMessages are being sent from email not phone number
Hdavies20
Member

I just upgraded from a 4 to a 6. My iMessages are coming through with my email as my contact not my phone number. I've tried unchecking my email but then iMessage won't work. How can fix this? It's annoying to those receiving my texts.

Labels (1)
0 Likes
Re: iMessages are being sent from email not phone number
vzw_customer_support
Customer Support

Hdavies20, congratulations on your uprgade to a new iPhone 6! We're so excited for you. You can remove your e-mail address and assign your mobile number in Settings>Messages>Send & Recieve>Select your mobile number.


For more device support, click http://www.verizonwireless.com/support/



LasinaH_VZW
Follow us on Twitter @VZWSupport
If my response answered your question please click the "Correct Answer" button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: iMessages are being sent from email not phone number
Weth
Sr. Leader

Clarification, in settings/messages/send and receive, select your phone number in "start new conversations from"

Re: iMessages are being sent from email not phone number
jessica0811
Member

this just happened to me.  I resetted my phone and then waited acouple of minutes and it works now

0 Likes