My Verizon app, can't authenticate or sign out. All I can do is uninstall and re-install and cross my fingers.
Enthusiast - Level 3

This issue actually has nothing to do with an iPhone 13. My current phone is an iPhone 14 Plus. But this issue has nothing to do with the specific phone that I have anyways.

When I bring up the  My Verizon app, typically I can't access anything on it. I get "Error Access denied. You are not device authenticated (403)." If I try to sign out, I get the same error. If I shut the app down and restart it, I get the same error. If I uninstall the app, I can sometimes use it after I sign back in. Other times after uninstalling and reinstalling I get "Unable to access now, try again later" or something like that, which soon changes to "Error Access denied" as above. And I'm back to uninstalling and reinstalling.

This is the worst app I've ever used, I'd be ashamed to have my users having to put up with this. Does Verizon ever intend to make this work app work well and consistently? Never had an app that I needed to uninstall and reinstall so many times just to get basic functionality occasionally. A lot of times I just give up and go back later when I have time to uninstall and reinstall it. Usually I end up on the web using my account there...which simply means that there's no mobile method of doing anything with Verizon, I have to be home to use my desktop computer.

Wondering if there's anything that I can do to make this app work as it should? Am I missing something major here? I'm willing to try anything to waste less time trying to use this app. Anything work consistently for anyone?

Labels (1)
0 Replies