WiFi calling not working IPhone 12 Pro Max
Enthusiast - Level 1
  • I've spent countless hours for over a week now trying to get my WiFi calling working again. I've had several support sessions with Apple in which they remotely viewed my phone screen. They had me do all the different troubleshooting steps including resetting my network settings with no luck. I had an Appointment with Best Buy geek squad set up through Apple. They did diagnostic tests & found nothing wrong with the hardware & the software is up to date with iOS 14.4. They popped out the 5G SIM card & put it back in to see if that would enable the WiFi calling but it didn't. They said everything with the iPhone is working properly so it has to be something wrong with how Verizon has your phone set up to the network or the wrong provisions. I had an appointment at my local Verizon store with no success in fixing the issue. It's only been about 6 weeks since I paid $1500 for iPhone 12 Pro Max 512 GB & already, about a week ago, my WiFi calling suddenly stopped working. It wasn't too long after I updated iOS from 14.3 to 14.4 that the issue began occurring. It is enabled in the settings but doesn't show up in the upper left corner of the taskbar as VZW Wi-Fi as it should. I only typically get 2 bars of signal at home so WiFi calling is important for me. When I brought my phone into the local Verizon store, I brought up the issue about my phone not being set up right to the Verizon network or the wrong provisions according to Best Buy. The Verizon solutions manager said, "That is way past my pay grade." He tinkered with it for awhile & couldn't get it to connect to Verizon's store WiFi that isn't password protected. He thought he had it fixed by setting it to airplane mode since the VZW Wi-Fi turned on in the taskbar and he was able to make a call to his personal hotspot WiFi on his phone since it is a password protected WiFi. He said that WiFi calling will only connect to a password protected WiFi network. He was confident it was now fixed because he said that airplane mode turns off cellular so the call has to be made with WiFi calling. I asked him, "So when I disable the airplane mode & get home, the WiFi calling will be enabled to my WiFi router?" He said definitely as long as it's password protected, (which it obviously is). When I turned off airplane mode & got home, WiFi calling still doesn't work. It will only work if I keep it in airplane mode which would be pointless. I came to realize from reading within this forum that many other users with this same problem could only get it to work with airplane mode but that doesn't fix the issue. My WiFi works with every other device in my home including my iPad so it's not my WiFi network. I  Just in case, I tried it on a couple other WiFi networks of my neighbors & WiFi calling wouldn't connect either even though it's enabled in the settings. I would appreciate some prompt help. Thanks
Labels (1)
Tags (1)