phone number shows as restricted
Reptile_Lover
Newbie

My phone number shows as restricted on caller ID's when I call people. I don't like this. How can I change it? I never changed it to reflect a blocked number, so I don't know how to fix the problem.

Labels (1)
  • Apple

0 Likes
Reply
1 Solution
Snn5
Legend

I saw this works on GSM phones, CDMA Verizon phones may be different.

Try: Settings - Phone - Show my caller ID = On

or

My verizon-->my services-->my plan-->under additional features-->click add/remove features/apps/programs-->select phone line-->Scroll down to basic features-->Caller ID Blocking-->Remove-->Continue

View solution in original post

0 Likes
Reply
6 Replies
vzw_customer_support
Customer Service Rep

Reptile_Lover,

That would definitely be frustrating if no one could see your number! If you check your account, does it show caller ID blocking is set up? http://vz.to/18VqThO Does this happen on all calls or only some?

AndrewT_VZW
Follow us on Twitter @VZWSupport

0 Likes
Reply
Inzombiak
Enthusiast - Level 2

all blocks are off, still shows as restricted, shared id not working, 5 hours on chat and still showing as restricted

0 Likes
Reply
elliew
Specialist - Level 1

On MyVerizon (verizonwireless.com) you can set your ShareName to display whatever you wish.

0 Likes
Reply
Inzombiak
Enthusiast - Level 2

Doesn't work

 

0 Likes
Reply
Snn5
Legend

Yeah, but that is changing the name of the display AFTER you have unblocked your number from displaying.

0 Likes
Reply
Snn5
Legend

I saw this works on GSM phones, CDMA Verizon phones may be different.

Try: Settings - Phone - Show my caller ID = On

or

My verizon-->my services-->my plan-->under additional features-->click add/remove features/apps/programs-->select phone line-->Scroll down to basic features-->Caller ID Blocking-->Remove-->Continue

0 Likes
Reply