Lack of Professional Customer Service

I just spoke to Bam in customer service (she would not provide me with any other professional identifying information about her) in regard to two matters concerning my account. First, I waited on hold for 39 minutes to speak to the rep after I a message said hold time was approximately 13 minutes. The first reason I called regarding the Visa gift card registration was resolved and she was great with that. Then I asked for information to register my military status to get the discount on my account. The website she gave me ( did not work. I kept getting errors. She told me Verizon was doing maintenance on the site and to try back in a few days. Before I got off the phone with her I asked her to check the website so she could see what I was talking about, but when she entered the link, she was able to get on the site. That didn't make any sense to me. She asked what browser I was using and said it might not work on Safari and she was using Google Chrome so maybe that was the problem. (That didn't make any sense to me because I have been able to access every other Verizon site on Safari.) So, I tried Chrome and still same issue. She again told me that the site was under maintenance and that was probably the problem and to try again later. I would not end the call because I wanted an alternative option to add my military status to my account. She basically informed me there was no other options. I told her I wanted to speak to a supervisor because I called last week and was on hold for 35 min before I could speak to someone but I had to hang up to go to work, I had waited 39 min to speak to someone tonight and I did not want to have to go through that again to get an answer. The rep began telling me I would not get a different answer from her supervisor and was going on and on, talking over me and not listening to anything I was saying. She was unbelievably rude. My response was raising my voice and trying to break in to get her to quit talking. After a moment of major frustration, I was able to get through and demanded to speak to her supervisor. She told me I would be on hold for an indeterminate amount of time and I said that was fine. She put me on hold and came back on the line 3-4 times to tell me her sup was still on another call. I continued to wait. While I was waiting, I searched for my own answers online and finally figured out that the problem I was having was the website I had entered because I did not understand her correctly. Instead of, I had to use "connections" to access the site. I waited on the line for Bam to come back on and just as she returned to the line, she finally decided to try to clarify the link she had given me at which point I told her I had already figured out the problem, but I asked for her information to file a complaint about her handling of the call and unprofessionalism. In turn, she told me she would be making her own notes on my account. Seemed a bit threatening, but I told her she was welcome to do whatever she felt was necessary. I told her the call could have gone so much differently if she would have just tried to clarify the link from the beginning instead of getting loud, talking over me and trying to put me off. I thanked her for her time and resolution of my first issue, but I didn't appreciate her handling of the rest of the call. I have other services with Verizon and I was dreading the customer service support getting Fios, as well, but after speaking to family and friends, they all told me customer support was the sacrifice I would have to make for using the service. It was Verizon or Cox where I live, and I almost regret not going with Cox. The TV service with Verizon is fine, but I got the Fios Gigabit connection and it is not what I expected. It lags and falls short of living up to the hype in their advertising. I guess it is what it is, but it's sad to see so many complaints and have to deal with the headaches. I dread ever having to call back for anything else.

Re: Lack of Professional Customer Service

I am not going to quote your long diatribe. Sorry

simple fix. 

the above is the correct way to enter the web portal. It’s reachable on all browsers and I used a iPad and it’s functional. You simply did not include the “s” on “connections”