"Not Supported Method" error when trying to sign into MyVerizon with Chrome Browser
EvanVanVan
Enthusiast - Level 3

For the past week or two whenever I try and log into the MyVerizon site to check my bill I get an error message saying "Not Supported Method".  This happens weather I use login screen that pops up when I first visit the site, use the login boxes on the right side of the page, or use the "Sign In" button in the upper right hand corner of the screen.

Same issue as here: http://www.google.com/support/forum/p/Chrome/thread?tid=126522d6d3ccb9dd&hl=en

I'm on the latest Chrome browser: 15.0.874.106

P.S. I just found an inconvenient workaround coming to the forums here to sign in first.. It seems I'm now logged in across the rest of Verizon.

Please fix this, I'd like to be able to sign into my MyVerizon account directly like I was able to a few weeks ago..

37 Replies
Justin46
Legend

@th3rtythr33 wrote:

Justin, please try logging out and in again. This is a widely known problem and has been reported numerous times on this forum, Google's Chrome forums, and in various other places. The problem definitely exists and is not caused by user error. It is directly related to the existence of the signin.verizon.com cookie.

......



I have, many times. Works ok for me. If there is a cookie issue I don't see it, maybe I have my cookie handling set differently from you (and others). Also I am not using the "keep me signed in for two weeks" option, could that have something to do with it?

All I know is that I can log into My Verizon when I first start Chrome up, I can log out and immediately log back in, as many times as I want (at least it appears that way).

__________________________________
Justin
FiOS TV, 25/25 Internet, and Digital Voice user
QIP7232, QIP7100-P2, IMG 1.9
Keller, TX 76248

FloridaFiOS
Enthusiast - Level 2

Cleaning browsing-history (incl. cookies) solved the problem for me..

0 Likes
th3rtythr33
Enthusiast - Level 3

@Justin wrote:

Also I am not using the "keep me signed in for two weeks" option, could that have something to do with it?


No, I'm not using that either. Also, this happens to me on 5 different computers on 2 different networks.

Try this. Log in in chrome, then close the browser window. Then start chrome and try to log in again. Does this recreate the problem?

0 Likes
Justin46
Legend

@th3rtythr33 wrote:
.... Also, this happens to me on 5 different computers on 2 different networks.

Try this. Log in in chrome, then close the browser window. Then start chrome and try to log in again. Does this recreate the problem?


Worked just fine.

1) Started Chrome, logged into My Verizon just fine.

2) Closed Chrome (did not log out from My Verizon before closing the browser).

3) Started Chrome, logged into My Verizon just fine.

I also tried it logging out of My Verizon first, same result, works fine each time.

Two different networks? Meaning Verizon and some other ISP or what? I am on a Verizon FiOS connection.

__________________________________
Justin
FiOS TV, 25/25 Internet, and Digital Voice user
QIP7232, QIP7100-P2, IMG 1.9
Keller, TX 76248

th3rtythr33
Enthusiast - Level 3

Meaning Verizon FiOS (home) and Verizon Hi-Speed DSL (office) with two different routers, network cards, etc.

If we can recreate the problem on your computer, it will help immensely, but I'm out of ideas for now. Thanks for helping!.

0 Likes
Justin46
Legend

@th3rtythr33 wrote:

Meaning Verizon FiOS (home) and Verizon Hi-Speed DSL (office) with two different routers, network cards, etc.

If we can recreate the problem on your computer, it will help immensely, but I'm out of ideas for now. Thanks for helping!.


Well unfortunately I am apparently not helping....

Any chance we are using different URLs to reach My Verizon? I am using:

https://www22.verizon.com/Foryourhome/MyAccount/Unprotected/UserManagement/Login/Login.aspx

Really, I am out of ideas too.

__________________________________
Justin
FiOS TV, 25/25 Internet, and Digital Voice user
QIP7232, QIP7100-P2, IMG 1.9
Keller, TX 76248

0 Likes
juxta
Enthusiast - Level 3

It worked for me... Tools --->  Clear browsing data  ---->  Delete cookies and other site and plug-in data (from last 4 weeks).

VZ has been tweaking the website lately, so the old cookie may now be bad/invalid.

0 Likes
th3rtythr33
Enthusiast - Level 3

People (like myself) are having the problem return after we have already cleared cache and cookies. It happens as soon as I log out and try to log in again.

Justin, it's happening everywhere on the Verizon website, and even when trying to sign in to Verizon on the HBO Go website (which is a system controlled by Verizon, it's the same login module in an iframe).

0 Likes
Justin46
Legend

@th3rtythr33 wrote:

People (like myself) are having the problem return after we have already cleared cache and cookies. It happens as soon as I log out and try to log in again.

Justin, it's happening everywhere on the Verizon website, and even when trying to sign in to Verizon on the HBO Go website (which is a system controlled by Verizon, it's the same login module in an iframe).


I am not a regular user of Chrome, I prefer Firefox. But I have had Chrome installed for several years and I do use it occasionally, mostly to try things out for a website I support. It is most certainly not my "production" browser, and I am far, far, far from being an expert on it. But here are my Privacy settings, maybe something will jump out at you about why I don't have a problem.

image

image

image

image

I have no exceptions in the "Manage exceptions..." link above.

Do any of the above settings differ from yours?

__________________________________
Justin
FiOS TV, 25/25 Internet, and Digital Voice user
QIP7232, QIP7100-P2, IMG 1.9
Keller, TX 76248

0 Likes
leafygreen
Newbie

I'm also having this problem and clearing the cache doesn't fix it. 

0 Likes
shrugger
Enthusiast - Level 1

Not sure if this will help anyone identify the problem or not, but I am also getting the Not Supported Method error in Chrome.

However, when I logged in to these forums from Chrome, I had no problem. And, logging into the forums has carried over into the rest of the website. So, now when I go to log into My Verizon, it has me already logged in.

There seems to be something different about the login scripting being done on the main My Verizon login that doesn't play nice with some configurations of Chrome and Firefox. However, something is different about other login scripts on the Verizon site that does not produce the same error. Perhaps those differences can be looked at to identify the problem?

NormT
Enthusiast - Level 1

Found a solution on Chrome site.  Obviously they know more than the 'foreign' Verizon employees.  Go to http://webmail.verizon.net/signin/  and sign in and you will have access to your account.  No more getting rid of cookie crap!

0 Likes
sunman1
Enthusiast - Level 2

This error is being reported on several forums.  The problems have been primarily reported with Google Chrome as well as Firefox and now IE so it appears to be unique to Verizon's sign in application.  

There are several solutions to use Chrome and other browsers at:

http://forums.verizon.com/t5/Verizon-net-Email/Google-Chrome-Users-and-Not-Supported-method/td-p/389...

you may find that using this link or webmail may allow you to log in without the "Not Supported Method" error.

0 Likes
th3rtythr33
Enthusiast - Level 3

No, I don't see any differences here. 

Until Verizon, its web software supplier, or Google own-up-to and fix this issue or we figure out what is really causing it ourselves, this should work as a temporary solution with a few caveats:

  1. Click the Wrench button on the Chrome toolbar.
  2. Click Options in the drop-down menu.
  3. Click Under the Hood from the list on the left.
  4. Click the Content Settings button.
  5. Click the Manage Exceptions button.
  6. Where it says "add a new hostname pattern," type: [*.]verizon.com
  7. From the drop-down to right of where you just typed, choose Session Only.
  8. Close and restart chrome and see if this has solved the problem.

Notes: 

  • You will not be able to stay logged in for two weeks by clicking the "keep me logged in for two weeks" option when signing in to My Verizon. Upon closing Chrome, you will be signed out again.
  • If you sign out of My Verizon, you will not be able to log back in until you completely close and restart Google Chrome.
0 Likes
Spiral9
Newbie

It is a pain and I could swear that just a few weeks ago I was able to log in from Chrome without problem.  Thank you though for the workaround of logging into the forums first.  I tried several different ways and couldn't find any, so it's nice to know that going through the forums works at least.

0 Likes
th3rtythr33
Enthusiast - Level 3

I had just started a new thread... I pasted the contents of that below. I should have looked around first. Smiley Wink

The problem also exists in Firefox, as you can see here. The problems seem to be related to the signin.verizon.com session cookie, which is not cleared between sessions or when logging out. It's presence is definitely preventing me from logging in, as if I manually delete that cookie I will then be able to log in right away with no problems. If you are someone testing this, please be sure to try logging out and then logging back in. Logging in the first time is no problem.

Another workaround that has helped me is to press CTRL+SHIFT+N to open an Incognito window, then I just log in and use My Verizon in there. Easier than clearing cookies, and better than using Internet Explorer IMO. Keep in mind that disabling all of my extensions in Chrome and add-ons in Firefox had no effect.

You can see what this looks like here:

The problem also affects other areas of the site, such as when trying to log in to the upgrade center.

giveup3
Newbie

Van: I was told by a Verizon Tech that Verizon was no longer supporting Chrome. I have the same issue. I cannot use Explorer because my home page starts pagenations at the top, just one after the other. When I use Chrome I don't have a problem. If Verizon does not fix this problem with Chrome, I will go back to Brighthouse.

0 Likes