Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Updated Phone
Katdoz
Member

I apologize if this has been addressed in another post.  I couldn't find an answer while I was searching.  I just updated my Blackberry Curve 8530 from 5.0.0.337 to 5.0.0.886.  Prior to the update everything worked smoothly.  Now I can't send an SMS text to anyone in my contact list who has Verizon service.  I can text two people in my contacts who are on a different wireless service.  I can receive texts from everyone but If I respond they won't get it.  I can still send email and MMS messages.  I don't know where to go to look for the answer.  Any help would be appreciated.  Thanks.

Tags (4)
0 Likes
1 Solution

Correct Answers
Re: Updated Phone
Katdoz
Member

Thanks Doc and Morgan. All seems to be working well now. 

View solution in original post

0 Likes
Re: Updated Phone
StreetDocRN
Leader
Leader

Hi,

Sorry to hear about your texting problem.  I have not heard too much about problems with that update, but I will look around and see what I can find for you.  Do me a favor for now, try to re-register your host routing table and resend your service books.  Go to Options>Advanced Options>Host Routing Table.  Press the Menu key and select Register Now.  Then, go to Email Settings and press the Menu key.  Select Service Books.  Select Send Service Books.  Then, pull your battery and allow for a device reboot.  After you are back up and running, test your SMS texting and see what happens.  In the mean time, I will look around to see if anyone else has reported this problem.  Thanks...

Doc

 

0 Likes
Re: Updated Phone
StreetDocRN
Leader
Leader

Hey,

Ok, I think I found your problem.  I recall a couple of weeks ago a similar post.  The problem is with the telephone number that is being associated with the number that you are texting.  The new OS puts a 1 in front of the number.  Fix this by going to Options>Phone Options>Smart Dialing.  Set the following:

Country Code:  United States +1

Area Code:  (what ever yours is)

National Number Length:  9

Use 1 for National Dialing:  NO

Local Country Code:  United States +1

Press the Menu Key and Save

When you enter your telephone numbers in your Address Book, you do not need to place a 1 in there.  Just enter the area code and the telephone number...ie  123-456-7890

I think this will fix your problem.  Let me know.

Doc

 

0 Likes
Re: Updated Phone
Katdoz
Member

Thanks for your suggestions.  I  will give them a try when I get home from work. 

0 Likes
Re: Updated Phone
StreetDocRN
Leader
Leader

Katdoz wrote:

Thanks for your suggestions.  I  will give them a try when I get home from work. 


Try the last suggestion first.  I believe it will solve your problem.  Let me know if it worked.  Thanks...

Doc

0 Likes
Re: Updated Phone
MorganB
Sr. Member

Just to add to StreetDocRn's post, there is currently an issue with RIM Curve (8530) & Curve 3G (9330) Devices Not Able To Send SMS Messages to 11 digit addresses. As a temporary solution, customers should address all SMS messages to 10 digit addresses. In addition, the customer should delete any message threads containing 11 digit addresses and compose new threads using 10 digit addresses. The issue is being addressed at this time. 

0 Likes
Re: Updated Phone
Katdoz
Member

Thanks Doc and Morgan. All seems to be working well now. 

0 Likes