Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
***Announcement: We’re excited to inform you that we will be merging the Fios and Wireless Communities to a unified Verizon Community with a new look and feel throughout. If you are interested in what specifically has changed, please see the New Revamped Community article under the Featured Topics.***
VZAccess Runtime Error
Blue-R
Member

 

I have a few users that are receiving the following error and I believe there will be more (they were ghosted and all have VZAM on the image).  

 

A window opens stating a Runtime Error then VZAM is forced closed:

Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:\Program F... (I believe it points to VZAccess Manager.exe)

This application has requested the Runtime to terminate it in an unusual way.

Please contact the application's support team for more information.

 

This is is the Application Event Log:

Faulting application name: VZAccess Manager.exe, version: 7.0.14.2, time stamp: 0x4ae24d5b

Faulting module name: rim_serial_sm.dll, version: 2.2.0.12, time stamp: 0x4a81caca

 

Two were fixed by uninstalling/rebooting/reinstalling, though did not work for another user.

 

These are brand new laptops, all updates applied.

 

OS: Windows 7

VZAM ver. 7.0.14(2397a)

When the device is connected (Blackberry 8830 or 9630) it is detected and the drivers are installed.  The SD card can be accessed and all looks well.  When VZAM is opened and it tries to detect the device is when the error occurs. 

It also errors when starting VZAM first then plugging in the BB.  

 

Faulting application name: VZAccess Manager.exe, version: 7.0.14.2, time stamp: 0x4ae24d5b

Faulting module name: rim_serial_sm.dll, version: 2.2.0.12, time stamp: 0x4a81caca

 

I have tested on a machine today before it joined the domain and before installing cisco vpn clients (AnyConnect and the IPSec Client (latest and greatest)) and i seemed to work fine. I will be testing on few other machines to see if stops working after joining domain and adding Cisco clients.

 

Any help would be appreciated. I will be traveling next few weeks to swap laptops with our users (100+) and NEED to find asure fix as they use VZAM daily.

 

Thanks.

 

Labels (1)
0 Likes
Re: VZAccess Runtime Error
lutherhex
Member

I had the same errors as you, different memory register, of course.

Faulting application vzaccess manager.exe, version 7.0.14.2, faulting module rim_serial_sm.dll, version 2.2.0.12, fault address 0x000135ce.

 

This was on a WinXP Media Center PC, using 4 different local user accounts (all admins, this is a family computer). I had installed the VZAccess software under one profile and it worked great. I logged out and tried a different user acount, and that is when I recieved the Runtime access error and the event logged. I tried repairing the program from Add/Remove, but that didn't work. What did work was simply running the VZAccess software installation again - even though it was already installed (which it did complain about, just ignore it).

The first thing the installer does is install the hardware drivers, which is great since the ZVAccess software crashes at the "detecting devices" dialog. It will not do a complete install, but rather exit after re-installing the device drivers, for which ever user account you are logged in as, stating that this program is already installed. Now the program works great and so does the DUN connection it creates - no need to restart or plug/unplug device.

 

My theory is that the hardware drivers are for some odd reason either referenced or stored in the user's local profile or Current User registry hive. If you need to do this for multiple computers, I would look in registry first and extract those entries to a .reg file and put into the All Users startup folder (or Active Directory) so it can be done each time anyone logs in. Just my 2 cents, best of luck.

0 Likes
Re: VZAccess Runtime Error
JB21386
Novice

What version on VZAccess manager? VZAccess manager has known issues with Windows 7

0 Likes