Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
4G LTE 4510L hotspot/mifi device won't stay connected redux ([RUIAUTO] Invalid packet state)
jasonj11
Member

There is a previous thread marked as solved which I have reviewed completely.  

 

This has not solved my problem.  This has been a problem for me for about a month - the device is essentially unusable in any market (4G or 3G).  In the diagnostic logs I see a lot of "[RUIAUTO] Invalid packet state" errors.  

 

System Log> HTML Version 25.

10/05/11 10:42:49am> Current Time

10/05/11 10:42:47am> NWPM_EVENT_CALL_CONNECTED

10/05/11 10:42:47am> LTE Connected

10/05/11 10:42:37am> NWPM_EVENT_CALL_END

10/05/11 10:42:37am> LTE Disconnected

10/05/11 10:42:37am> [RUIAUTO] Invalid packet state

10/05/11 10:42:13am> NWPM_EVENT_CALL_CONNECTED

10/05/11 10:42:13am> LTE Connected

10/05/11 10:42:05am> NWPM_EVENT_CALL_END

10/05/11 10:42:05am> LTE Disconnected

10/05/11 10:42:05am> [RUIAUTO] Invalid packet state

10/05/11 10:41:27am> NWPM_EVENT_CALL_CONNECTED

10/05/11 10:41:27am> LTE Connected

10/05/11 10:41:17am> NWPM_EVENT_CALL_END

10/05/11 10:41:17am> LTE Disconnected

10/05/11 10:41:17am> [RUIAUTO] Invalid packet state

10/05/11 10:40:54am> NWPM_EVENT_CALL_CONNECTED

...

Model MiFi4510L

Router FW Version 02.01

Modem FW Version 2.16.07

AP FW Version 2.10-3.0.0.5

ERI Version 4

PRL Version 15024

 

What should I try next?

 

0 Likes
Re: 4G LTE 4510L hotspot/mifi device won't stay connected redux ([RUIAUTO] Invalid packet state)
John_Getzke
Leader
Leader

Jason,

 

Your link is not formatted correctly but I was able to pick it apart to find what you were referencing.  Unfortunetly you linked us to one of the largest threads in this forum so its unclear which steps you have already tried.  Lets start fresh and keep it this thread specific to your problem.

 

In general the easiest thing we users can do is reset the device in a few different ways:

Level 1: Power on/off the device

Level 2: Remove the SIM card

Level 3: Press and hold the RESET button under the back cover

 

The next level of troubleshooting requires reconfiguring the MiFi.  Here are some generic steps which may help you:

1. Lower the 802.11 Mode from B/G/N to B/G

2. Restrict the device to 3G only (assuming you are in range of 3G)

3. Remove the Wireless Password by switching the profile type to "Open"

 

The most difficult troubleshooting would involve decrypting why your MiFi is displaying the "RUIAUTO" error message.  At that point it might be easier just to have your MiFi swapped out under warranty than to get to the bottom of it.  Lets save those steps for last. 

 

0 Likes
Re: 4G LTE 4510L hotspot/mifi device won't stay connected redux ([RUIAUTO] Invalid packet state)
jasonj11
Member

Sorry about the bad link - the previous subject was "4G LTE 4510L hotspot/mifi device won't stay connected"

 

Yes I have performed all corrective actions.  I work for a very large verizon national account and it has taken me days to navigate through to the right person that can help but i have a replacement 4g LTE and SIMM card on the way.

 

I'm not that smart about technology but it mystifies me that the modem can connect long enough to transfer some packets and then get tripped up in the "invalid packet state" loop.  Everyone agrees though that my device must have gone bad.

 

 

0 Likes
Re: 4G LTE 4510L hotspot/mifi device won't stay connected redux ([RUIAUTO] Invalid packet state)
John_Getzke
Leader
Leader

You are not alone with your mystification.

 

I can say that noone else has reported the RUIAuto error message on this forum or anywhere else according to my websearches.  Its unclear exactly what that error message is trying to tell us so all we can do is guess.  Let us know if your problem comes back with the replacement MiFi or not.

0 Likes
Re: 4G LTE 4510L hotspot/mifi device won't stay connected redux ([RUIAUTO] Invalid packet state)
jasonj11
Member

UPDATE: I got a replacement 4G LTE and a replacement SIM card.  For whatever reason the verizon system could not activate my new SIM card - so I was directed by support to reuse my old SIM card.  

 

Long story short - I thought I traced my problem down to an application i had installed on my laptop VMware Workstation 7.1.  I unstalled VMware and thought that "fixed" my problem and I wrote this nice article about troubleshooting this invalid packet state error.  And then I fiddled with the 802.11 setting putting it back to factory default (802.11g + 802.11b + 802.11n) and then my stuff broke again.

 

So I still don't know what my problem is but I'm convinced that it must have something to do with my laptop - Windows XP SP3 and perhaps this 802.11 setting which I've changed and tested multiple times.


Since I seem to be the only person in the world having this problem I'm also hoping I'm the only person in the world still running Windows XP SP3.  My box gets wiped clean this week so thats what I'm hoping will help fix my problem.

 

0 Likes