Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
FTP packets blocked?
AverageJow
Newbie

Interesting issue I'm having. I'm able to ftp within my local network perfectly, however if I try to access it through the internet I can connect to the server but I can't transfer files. So I did a lot to troubleshoot the issue...

I have already set port forwarding for my ftp ports, and I even set some random ports and changed the port number my server is listening to, same issue.

I wrote a program that uses all the ports I've tried and my program I wrote works perfectly. So I know I can access the ports themselves through the internet.

I've tried Windows IIS, apache through windows, and apache through linux. All have the same results, local area works, and either I can't transfer files or I get access denied(even with anonymous, and I test anonymous with my local network and it also works fine.)

I have tried being a DMZ host and turning off the firewall.

It seems to all come down to packets sent. Is verizon sniffing packets and discarding ones with FTP traces in them? I bet I can write my own program to be a basic file transfer app and make it work that way, so its kinda ridiculous that they would be packet sniffing. Thoughts?

0 Likes
Re: FTP packets blocked?
John_Getzke
Champion

I have not experimented with FTP on the new VZW devices but I would assume you are hitting the same limitation as everyone else.  The fact that you mention setting up a custom port leads me to think that your traffic will not be allowed on the SIM card network.  This is a result of the NAT firewall that controls the new network and the communication that goes across it.

The best use of your time would be to locate a free VPN and set it up for your home FTP server and your remote machine.  Once the two machines are on the same VPN they will be allowed to transfer files without any issues.  The only other likely work around would be to purchase a public IP Address.  If your IP was public then your custom ports would work too.

0 Likes