Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring your phone. Plus, waived smartphone activation fee when you buy online. Limited time offer.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
MIFI Device being recognized by Win 7
skhofmann
Member

After several attempts to get two laptops to recognize my 2 Verizon MIFI 220)'s, I finally found a workaround. 

 

First, I could not get the VZAccess version 7.2.7.1 (2462a) to install (after downloading from the Verizon tech support site), failing each time with a cryptic:

 

Mobile Broadband Generic Drivers:

Error 1720, stating that was a problem with this Windows installer package.  A script required for this install to complete could not be run.  Contact your support personnel or package vendor.  Custom action

UnistallDrivers32.5F1DC02E_0598_466_8B42_4C5AA41526BB script error -2147024894. : Line3, Column 1.

 

I tried all the traditional steps, uninstall, reboot, reinstall,

Run as admin

Run in compatibility mode, etc

 

I finally submitted a help ticket and was mailed a driver disk which included the 7.2.7.1 and (in theory) drivers and a firmware update.

 

The Mobile drivers WOULD NOT INSTALL for the MIFI 2200, with an equally cryptic windows installer error,

 

However, the VZAccess installed fine,but would still not recognize the device when connect via USB, nor would Win 7 recognize the device,..

 

The Firmware update executed, installed to Win 7, but since the machine could not see the device, of course it could not update the firmware,..

 

So, I took a gamble that the "CD ROM software" embedded in he MIFI might be the culprit,.. which is apparently the case.  I opened a Win 7 explorer window, the selected "Eject" for the CD ROM mapped to the MIFI, and viola, the machine started to install the device drivers for the MIFI Modem, and a GPS port, and a Status port,...  concluding with a successful install!

 

Next, starting up VZAccess, for the first time since the Win 7 upgrade, it recognized and install the MIFI in tethered mode (not WI-FI mode).  I was able to connect, update the PRL, check for updates, and was even offered the option to upgrade the firmware,...

 

The firmware upgrade executed fine, except when VZAccess tried to locate the device after the upgrade, it indicated the firmware update had failed (not really).

 

I disconnected and reconnected the MIFI, and as expected, it was not visible, until I "Ejected" the embedded MIFI CD ROM device, then both Win 7 and VZAccess again located and operated WWAN the device correctly.

 

I have tried to disable the embedded MIFI CD ROM, but from either Win 7 device manager or VZ Access Preferences, I still must repeat the steps of "Ejecting" the MIFI embedded CD ROM (which is not worthless since it contains old VZAccess and Drivers but cannot be updated with new versions) to get the MIFI to be recognized,...

 

Hopefully this helps some of you -- it cost me dozens of hours of troubleshooting to get back to having the MIFI operate in USB mode (which is needed occasionally to allow updates the preferred roaming list and to check usage, monitor status, and check for updates).

 

 

0 Likes
Re: MIFI Device being recognized by Win 7
larrytheG
Member

I've never seen the VZACCESS/MiFI200 "CROM".. can you be specific as to where you saw it ? Was it at "MY Computer" and showed up as a CD-ROM drive labelled as MiFI?

 

0 Likes
Re: MIFI Device being recognized by Win 7
skhofmann
Member

You will see the MIFI CD ROM in either My Computer or Windows Explorer

 

(Labeled CD Drive X: VZAccess Manager

0 bytes free of xx.xMb

CDFS)

 

By default, the MIFI comes with its installation software and drivers installed on a "electronic" CD ROM embedded in the MIFI device,  which is recognized by the USB port when plugged in.

 

It seems in Win 7, this device gets recognized first, and prevents the OS from discovering the modem -- until you right click on the MIFI CD ROM (preceded by a Verizon icon) in either Explorer or My Computer, and say "Eject"

 

Still working the same way -- 4 hours after applying the "Eject" each time I want to tether the device,..

 

0 Likes
Re: MIFI Device being recognized by Win 7
DaveMertz
Member

Bring up VZAccessManager, go into the options and disable the MiFi's  CD-ROM drive.  Alteratively, disable the MiFi's CD-ROM drive in Windows Device Manager.

 

Dave

 

0 Likes