MiFi 2200 not recognized by Mac - problem solved

I wanted to share this with fellow Mac users in case they run into the problem I did -


I was able to connect my MiFi 2200 to my desktop iMac (Intel/aluminum/24") without difficulty - recognized the device right away and mounted the "CD" image. I installed the VZ Access Manager and was off and running. The instructions were exactly right.


Where I ran into trouble was when I tried to do the same with my Macbook Air --


The device was not recognized in the Finder's devices list, nor was it showing up in System Settings -> Network (I was hoping to add it manually at that point).


I did have Sprint SmartView installed and interestingly when I launched it, it saw the MiFi card and said it was "Not Activated" - it also did some updates to the card (which I was not expecting and kind of worried me).


I proceeded to uninstall Sprint SmartView (the uninstaller is in the Sprint SmartView folder in Applications), then downloaded the latest VZ Access Manager from ther Verizon Wireless support website.


After installing the VZ Access manager, it found the MiFi 2200 (again, remember it's plugged into the USB port), and indicated it was "Not Activated" - I indicated that I wanted to activate it, and the VZAM updated the card and activated it.


At that point the MiFi did show up in devices in Finder and the System Settings -> Network was updated with the new profile, and it was working normally.