Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
MiFi 2640L Jetpack 108D.. Won't Connect
MarkLH
Member

I have been using my new MiFi 2640 for roughly 3 months and when I woke up this morning I turned the device on and walked off to the computer. I tried connecting and nothing, it didn't show the network at all. I went back to the device and noticed it was stuck on the "MiFi" screen. I tried turning it off and it wouldn't even power down. I do not want to pull the battery to get it to reset so any advice would be appreciated.

My wife is a University of Pheonix student so its crucial we get this resolved ASAP, again any help will be appreciated.

Thanks,

-Mark

0 Likes
Re: MiFi 2640L Jetpack 108D.. Won't Connect
vzw_customer_support
Customer Support

Gadzooks MarkLH! I do hope you were able to get your MiFi up and running by now. I'm assuming you actually meant the MiFi 4620L Jetpack is the culprit causing the trouble, since we don't have a model 2640L. A battery pull is actually a good thing to do every once in a while to refresh the device's connection to the network. It's not going to actually reset any passwords of usernames for your Jetpack. If it's stuck at any point or won't power down using the buttons, that's the best thing to try first. If you don't feel comfortable pulling the battery, there's also a way to restart the device through your administration page. Here's more details if you'd like to check it out: http://bit.ly/SZEHHz.

Keep me posted if the restart didn't do the trick and let me know if you're seeing any error messages too.

JenniferH_VZW

Please follow us on Twitter @vzwsupport

0 Likes