Must manually connect MIFI 4510 to Vista on start up

I use my MIFI 4510 for Internet access with my Dell laptop running Windows Vista.  When I restart my computer with the MIFI on, it usually shows my laptop connected to the MIFI but with either local only or with limited access.  Both of those mean I cannot immediately access the Internet.  My solution has been to:

  1. Right click on the Network icon.
  2. Disconnect from the MIFI 4510.
  3. Select Connect to a Network
  4. Select the MIFI 4510.

After a few seconds, it will say I am Successfully Connected, a firewall window will appear briefly and everything will work fine until the next time I restart the computer.

My question is this.  Is there any thing I can change so I can skip the above steps and have it successfully connect without my help on start up?


4 Replies
Customer Service Rep

Hello, TommyToo!

I want to see the connection process become easier and it should be! Keep me posted if the steps provided by @John Getzke work for you (thank you btw)

Follow us on Twitter @VZWSupport


My current computer doesn't have wireless also i haven't used Vista, but Windows 7 should be similar, so sorry if my help is confusing.  This probably won't fix it, but its worth trying if resetting the mifi doesn't fix it.

I think you should try deleting the wifi access point and reconnecting to it

from the Network Center, there should be a Manage wireless networks (do NOT chose wireless adapters unless you're uninstalling and reinstalling the drivers)

find the mifi and delete it

restart your computer

reconnect to the mifi

you can also try uninstalling the drivers for your wireless adapter, and reinstalling the drivers

Champion - Level 1


You should not have to perform these steps unless something on your computer is tampering with your connection and dropping it.  Based on your description I would point the finger at whatever firewall application you are using.  It might be worth a shot to disable/uninstall the firewall for a day or two to see if it resolves your problem.

Try to capture the firewall error message and post it to this thread so we can see what you are talking about. Firewalls should not be involved when you are connecting to a wireless network. 

Aside from that you might want to consider deleting and re-creating your wireless profile for the MiFi.  Perhaps something is corrupted and needs to be cleaned up in that area.  You can manage your wireless profiles from the Network and Sharing Center.

If that doesn't work then I'd suggest trying out one of the many resets for the MiFi.  Resets are good for resolving temporary problems between your MiFi and VZW.  The symptoms you describe here do not appear to be in that area but it doesnt hurt to reset the device every now and then to be safe.

Level 1 Reset:

  1. Power down the MiFi
  2. Let the MiFi sit for 30 seconds
  3. Power on the MiFi
  4. Test the connection

Level 2 Reset:

  1. Power down the MiFi
  2. Remove the back cover
  3. Remove the battery
  4. Remove the SIM card
  5. Allow the MiFi to sit for 30 seconds
  6. Reassemble the MiFi
  7. Test the Connection

Level 3 Reset

  1. Power on the MiFi
  2. Remove the back cover
  3. Press and hold the Reset button next to the battery for 10 seconds
    a. Paper clip seems to work best for pressing the reset button
    b. Watch the MiFi E-Ink display to see if all the icons are displayed
  4. Release the Reset button
  5. Reassemble the MiFi
  6. Test your connection

Thanks for the advice.  The firewall message I see is not an error message, but confirms my AVG firewall profile. ... Based on your comments, I have done a little research and changed to a different firewall profile.  I'll see if that solves the problem and report back.