Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
My jetpack stopped working about a week after I got it?
wks221
Newbie

I bought he jetpack when I bought my phone, it was amazing when I first got it, the connection was fast, very reliable. Then it just seemed to stop working out of nowhere. It used to show my data usage, now the main screen says data usage not available. Whenever I try to connect to the wifi with any device it takes me to a random my.jetpack website. It won't let me do anything besides look at some settings and then hit cancel and be sent back to the wifi menu. I tried bringing it into the verizon store but the person told me they couldn't look up the account information at the store. I have tried fixing it myself but nothing is working. I bought this device because I thought it would be helpful being a college student who travels a lot to have a reliable source of wifi, but all I have done with this device is use it for a week then stick it in a drawer for six months while continuing to pay for it because I'm still holding on the hope that maybe someone can make it work. I don't know where to take it or who to call, its so annoying to have the device and pay for it but not be able to use it. Someone please help me!!

0 Likes