Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
Printer won't accept Jetpack™ 4G LTE MiFi® 4620L password
ABakke
Member

I have a Epson NX330 wireless printer that found the router and accepted the password the first time beautifully and then the next day lost it. I have since tried numerous times to reenter the password and get a set up failure message each time. I have turned the printer off and on and retried and up plugged it and retried. All my other devices accepted it the first time as well. the report says nothing helpful except that the connection is poor. I have 2 bars all over my house and all the devices are picking up the signal. Suggestions?

0 Likes
Re: Printer won't accept Jetpack™ 4G LTE MiFi® 4620L password
John_Getzke
Leader
Leader

I would start by moving your MiFi to the same room as the printer and see if you can get it to connect.  It might be a simple range problem where your signal is not strong enough to maintain communication with the printer.

If your MiFi is in the same room and is still not connecting then the next thing I would do is reset the defaults on the printer.  You will have to consult the User Guide for your printer on those steps, but performing a reset will clear out any bad/incorrect password settings it might have picked up.  After the reset try to re-enter your password credentials and see if you can get it to work.  Folks in this forum cannot really help you with your Epson printer, Epson support will need to be contacted for that. 

We can help you look up your password information on the MiFi and make changes to it though.  Id suggest navigating to www.vz.hotspot on one of your computers and look around the settings posted there.  Let us know if you need the steps to look up something specific.

0 Likes