Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
Showing results for 
Search instead for 
Did you mean: 
Issue with MMS APN and sending pictures

I recently activated a Droid2 that I purchased online, the phone was clean and after activation ran a restore of my settings from my previous Droid2.  Not sure about the ability to send pictures before the restore but since the restore I can not send pictures through text messaging.

I get the following error:

MMS Messages can not be sent or recieved until the data connection is restored.  Please check your MMS APN configuration in Mobile Network Settings.

when I go to the mobile networks setttings on my phone I have an option for system select for CDMA roaming mode (Home or Automatic) and nothing else.  There are no options to view or to edit at all.

I have no VPN settings setup either.

I have tried using Handcent SMS but that has not worked either.  Saw online the app Tweakker but get a message that it is not compatible with my phone when I tried to search for it.

This is getting very frustrating as I do not want to reset the fatcory defaults if at possible.

Tags (3)
Re: Issue with MMS APN and sending pictures
Customer Support

Hello, CMather79!

Let's get the picture messaging working for you! Thanks for doing a good deal of troubleshooting already! Are you able to access the internet browser and Play store like normal? Did you have a picture messaging block or restriction on your line before activating this new Droid 2? We may need to check at the account settings specifically. If you continue to have concerns, please send me (AdamE_VZW) a direct message for further assistance.

Follow us on Twitter @VZWSupport

Re: Issue with MMS APN and sending pictures

I can access the play store and other internet stuff fine. I had no restrictions setup on my line with my old phone either. After some looking I'm tanking that maybe it was a problem with my restore. I used mybackup pro and restored all phone settings as well as ems messages and settings. The problem I think I might be running into is that my old phone was a DROID 2 global model A956 and the new phone I bought used is just a DROID 2 model A955.