Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
Droid Maxx Unresponsive Home button, Called for a Factory Reset.!
B33
Sr. Leader

On my Droid Maxx late last night I realized something odd with it that was working fine earlier in the Day but Completely stopped when I tried using it the Evening,  And  that was the Home Button and a few other buttons the only one that was responding was the back button..  I tried running a couple system caches and power resets but in doing all of that nothing helped..


I tried pulling the Sim Card that did not work either the only thing that did work was when I Factory Reset it      After that all the buttons functioned & responded as they should.. 


If any Member on the Forum with a Droid Maxx, Droid Mini  or the Ultra has the same Experience, Follow threw with a Factory Reset  FIRST  before Returning your Phone to the Store for Replacement..  Hopefully in doing the Reset it will get the buttons to respond as it they are doing in my Case on my Droid Maxx..

B33  5 / 21 / 2014  10:14 AM

Labels (1)
0 Likes