Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Google Play services won't run unless you...
Fishsticks
Member

I updated to Lollipop. Now I have an alert that won't go away. All I can see is this:

Update Google Play

Google Play services won't run unless you...

I can't make it show me anything past the "you...". I assume it probably says (given the line above it) that I should update Google Play. Well, that would be fine, IF MY PHONE WOULD LET ME. But it won't. If I tap on the alert, it takes me to Google Play, but then the only options are "Deactivate" and "Open". If I tap "Open", it takes me to "Google Settings", where there is again no option to update. If I open Play, I can't update any apps because Play isn't updated, but I CAN'T UPDATE PLAY!

And to make it all more frustrating, I couldn't even type this message in this damned window because every time I tapped the space bar, it would duplicate the word I'd just typed but insert the second copy into the middle of the original. WTF?! (I had to go type this in a note app, then copy and paste it here.)

I'm about to throw my damned phone through the window!

Labels (1)
0 Likes
Re: Google Play services won't run unless you...
MiiHere
Leader

Have you tried deleting the cache and data for the google play store and restarting your device?

It should be under settings> and look for application manager, you'll probably need to scroll to find ALL and then find the app there.

0 Likes
Re: Google Play services won't run unless you...
KellyArens
Novice

You have already solved this problem, but mine did the same thing.  I powered off, waited a few minutes and powered back on.  No problems at the restart and that message went away.

0 Likes