Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
Incoming calls always "Unknown" ?
montill
Member

I just recently switched to Droid Razr Maxx HD. Everything works fine but all incoming calls have neither name nor number. They always come in as "Unknown" even when they are in my contacts. Especially family & friends are NOT ID blocked on their end. I checked all the settings and everything seems to be set the way it should be. Can anyone help, please?

Labels (1)
Tags (1)
0 Likes
Re: Incoming calls always "Unknown" ?
B33
Sr. Leader

Do you have your Caller ID on try that and with my Contacts i have all of them set up with Google On my Maxx's my Caller ID announces the calls before the Ring..

0 Likes
Re: Incoming calls always "Unknown" ?
vzw_customer_support
Customer Support

Quite an interesting situation you have going on here, Montill. I'm commited to helping you find a solution. Thanks to B33 for your input. I reviewed the options on your device, but I was unable to locate any option to turn caller ID on or off. I was going to suggest that you ensure that your contracts' numbers are saved into the phone correctly. For example: If your calls come from a ten digit number (xxx-xxx-xxxx), but you have the contact saved as seven digit number (xxx-xxxx) the caller ID on your device may not recognize the number. 

It's also possible that the caller ID feature is not on your account. Once you've confirmed how your numbers are saved into your device, let me know if you would like for me to review your  account. Follow me, send a PM (private message) and provide me with your wireless number. Have a great day.

ChaunceyM_VZW

Follow us on twitter @VZWSupport

0 Likes
Re: Incoming calls always "Unknown" ?
B33
Sr. Leader

Your Welcome.. Chauncey

0 Likes