Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
Power button not working?
mrsparkyz
Member

I turned my Droid Turbo off because I was having bluetooth connectivity issues. Upon trying to restart, I found that the power button was unresponsive. I tried to do a soft reset but, like I said, the power button seemed to do nothing. When I plug it in, it shows at 100% capacity. I unplugged, held the buttons in for a soft reset, and THEN plugged it in and THEN I arrived to the bootloader screen. I can navigate up and down, BUT still no power button with which to select an action. Does anyone have any input? Thanks in advance!

Labels (1)
0 Likes
Re: Power button not working?
Ann154
Expert
Expert

Which version of the Droid Turbo do you have?

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Re: Power button not working?
vzw_customer_support
Customer Support

Mrssparkyz, You’ve done some great troubleshooting on your own to get things going. If the device still won’t come on, we may need a hands on look at your device. Has there been any moisture or physical damage to the device? Have there been any recent updates to your device (software related)?

TakendraW_VZW

Follow us on TWITTER @VZWSupport

If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes