Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
cancel
Showing results for 
Search instead for 
Did you mean: 
When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
cjerchick
Member

When I connect my Droid Maxx to the PC i get a windows box asking me to insert disc (don't have) and when I check to have it look on the device it comes up empty.  On my phone I get an icon that comes up that says USB Debugging...  I would like to transfer pics and files to and from the pc to the phone.  Anyone know what the problem is?

Labels (1)
Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
Montel2
Novice

Try enabling USB debug mode in Developer options:

  1. Go into Settings, then scroll down to the bottom and click on AboutPhone.
  2. Scroll down to the bottom to where it says “Build Number”.
  3. Tap on “Build number” 7 times. After the third tap, Android will start counting down on how many taps are left before you can access the developer options, with a playful “You are now [insert number of remaining taps] steps away from being a developer”.
  4. After the 7th tap, you’ll get a “You are now a developer!” message.
  5. Now, go back to the main settings screen, and voila, the “Developer options” menu will be visible at the bottom, just above “About phone”!
  6. developer options->->"USB debugging" and check the box.

The next time you plug into your computer watch the screen on your phone, it should say "connected as a media device" at the top of the screen in the notifications area. then follow the prompts on your computer screen.

0 Likes
Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
cjerchick
Member

Thanks Montel2, I have done that and enabled Developer Options.  When the phone is connected to my computer the phone pops up an icon that says 'USB debugging connected' and 'touch to disable USB debugging' and when I touch or pull down I get the Developer Options screen on my phone.  Still does not show up as a drive on my computer. Thanks for the reply though!

0 Likes
Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
Jakeman1
Sr. Member

Go to google and look for Motorola Device Manager. make sure the latest is installed on your computer.

Plug in your phone. It should pop up in a few seconds.  If it does not pop up then look at your phone in the notifications area. Click on the USB symbol and select storage device or use as storage device (on your phone) it should now open a box on your computer.

Also try to make sure you are using the Motorola USB Cable that came with the phone. Not all USB Cables will work with this as some are charge only and do not have the other wires in them.

Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
cjerchick
Member

Thanks Jakeman1, I followed your detail and downloaded Motorola Device Manager to my computer and it is set up; then I downloaded Motocast to my Droid Maxx and it installed.  When I access the app on my phone it indicates that my phone is not a supported device.  I went to mymotocast.com and it said that the software has been updated for my phone so I downloaded again and then went to update and it is still indicating the phone is not supported.  I was able to transfer pictures from the phone to the computer but not any other type of data file (i.e. excel or pdf) to the phone?  Any suggestions?

Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
Montel2
Novice

Cjerchick,

  When the initial phone to computer connection is made, are you getting a

pop up window on the PC asking how to refer to connected device? From what

you've described, it seems like it is treating your phone as a camera and

not as a storage device.

Go to Start->search->type %temp%, a window with all temporary files should

appear. Press control +A to select all files in window then delete them.

Afterwards, try to connect your phone again.

Geoff

Private info removed as required by the Terms of Service.

Message was edited by: Admin Moderator

0 Likes
Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
cjerchick
Member

Hello Montel2:

                When I go to Search then type ‘%temp%’ I do not get any results, when I just type ‘temp’ I get 50 or more results from all different types of files.  What should I do?

Regards,

Chris

Better living through advanced Chemistry……

Private info removed as required by the Terms of Service.

Message was edited by: Admin Moderator

0 Likes
Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
Montel2
Novice

Delete them all.

Geoff

Private info removed as required by the Terms of Service.

Message was edited by: Admin Moderator

0 Likes
Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
Montel2
Novice

My thoughts are that if we clear the temp files it will treat the

connection as a first time attempt with no prior history and give you a

prompt with the option to treat it as a storage device or to open windows

explorer so you can see all files / folders on the newly connected device.

Geoff

Private info removed as required by the Terms of Service.

Message was edited by: Admin Moderator

0 Likes
Re: When I connect my Droid Maxx using a USB cable to my PC it doesn't recognize it?
cjerchick
Member

These files that show up are files that only contain the phrase ‘temp’ and are from a multitude of programs not just temporary files.  I am uncomfortable deleting them.   You are talking about the files on my PC correct?  Should I have typed ‘temp’ or ‘%temp%’ ?  The PC indicates that the device is a MPT and will allow me to transfer vids, pics and song files, and I can change to have it view the phone as just a camera, but nothing that allows me to see it as a storage device.  I can see the files on the phone from my PC but cannot transfer any data files to the phone.  It gives me an error message indicating that my phone does not support that type of file, etc.  Thanks for your responses.

Regards,

Chris

Better living through advanced Chemistry……

Private info removed as required by the Terms of Service.

Message was edited by: Admin Moderator

0 Likes