BHR4 Connectivity Issues with 5GHz Frequency - Is it fixed?
CrimsonGhost1
Enthusiast - Level 1

Has this ever been resolved with new firmware? The lack of update to pinned post tells me no, but I'd like to know for sure.

5 Replies
jonjones1
Legend

@CrimsonGhost wrote:

Has this ever been resolved with new firmware? The lack of update to pinned post tells me no, but I'd like to know for sure.


I believe the original thread said it was AFTER the new firmware update was released.

Jmwalker36
Enthusiast - Level 2

Except that was in January of this year... and the supposed ‘fix’ still hasn’t come & nor did the fact that I bought into their service plan without their disclosing this known issue.

0 Likes
Dan_J
Newbie

Has there been any update to this issue with BHR4 Connectivity Issues with 5GHz Frequency (Fios ONLY)?

0 Likes
efaust70
Enthusiast - Level 2

I got a new router the other week and replaced my almost 2 year old one. I noticed that it had newer firmware on it, but I don't remeber the actual number.

I was having 5g problems with my old router and continute to have them with the new one. I cant get it to connect with any of my devices.

I haven't gone down the rabbit hole of calling Verizon support, but my guess is that they haven't fixed it yet.

Jmwalker36
Enthusiast - Level 2

Nope, still not fixed... and don’t bother contacting Verizon.  I’ve spent days now attempting to troubleshoot the issue, speaking to one after another of the ‘technicians’ for a pitiful lack of answers.  This is unexceptable & what a disservice to their customers!!!! 

0 Likes