Certificate Error, Router home page hacked? (192.168.1.1)
corei7
Newbie

The router home page (192.168.1.1) is now showing as insecure.  I am being re-directed to myfiosgateway.com, which shows https with a red strike through, and which displays the following: 

 The redirected site is protected with a self-signed certificate, and your internet browser will prompt you with a security warning to accept the router's self-signed certificate before proceeding. This is a standard prompt for any self-signed certificate to help ensure the security of your internet connection.

Has this page been hacked? I did not log in.

0 Likes
73 Replies
CRobGauth
Community Leader
Community Leader

I have a similar trouble at work where they use self signed certificates for internal applications.

Its funny how they tell people to accept this warning but becareful when you go to other sites because those may not be trustworthy.

CuriousMinds
Newbie

Cannot login to https://myfiosgateway.com/ or https://192.168.1.1/ because of Certificate Error. The router is Verizon FiOS-G1100

When I try to login to either in any of the browsers e.g. Google Chrome, Internet Explorer or Mozila Firefox I get next error:

Your connection is not secure

The owner of myfiosgateway.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

Learn more…

Report errors like this to help Mozilla identify and block malicious sites

myfiosgateway.com uses an invalid security certificate.

The certificate does not come from a trusted source.
The certificate is not valid for the name myfiosgateway.com.

Error code: MOZILLA_PKIX_ERROR_CA_CERT_USED_AS_END_ENTITY

Then I click on the Add Exception button to store this Certificate anyway but it does not resolve the issue and I stuck having the same error over and over again.

0 Likes
CRobGauth
Community Leader
Community Leader

Worked just fine for my router.

I get the same errors you listed.

I did add exception and then got a login page.

What is intersting when I go to 192.168.1.1, I get a warning about security exception before proceeding to the page.

CuriousMinds
Newbie

What version of browser are you using?

I'm using Chrome Version 72.0.3626.121, Firefox 60.5.2esr, Internet Explorer 11.09600.19266.

All giving the same behavior - > showing the same error page even after I added stored this Certificate with Security exception.

Please note that it used to be working  before but on February 28 I did a hard Reset to my router and since then I'm having this issue. Maybe Router's Firmware has updated during hard reset but I can't check it since I can't login. P.S. Internet is working just cannot acces the Administrative page.

0 Likes
Zoey_DC
Enthusiast - Level 2

See my post on this thread -

Error connecting to Router - Certificate Error

The exact same thing happened to me, and it caused major issues on my network.  Actually, I think what happened is that we are now accessing our router setup on the internet at the myfiosgateway.com website, rather than connecting directly to the router in the home at 192.168.1.1.  I've never seen this before, but I don't know if you noticed, the router setup interface is not the same, some of the Advance Security settings are gone.  I have my network restricted using MAC address for devices, and now I can no longer get to that setting...?  Something major happened, but I can't figure out what happened, or how to get back to my physical router, eventhough I can connect using myfiosgateway.com?

0 Likes
waynebo
Newbie

I'm experiencing the same loss of MAC Address filtering. I was searching over and over, wondering where it went, after most of the kids came to me stating that their wireless devices don't connect to the either the 5GHz or 2.4 GHZ network today. I can't see any issues, but this Quantum router is a bit fugazi, and the WPA2 key stored at VZ is lending me to get a second Linux router to install behind the Quantum one--relegating it to a neutered direct-connect only Gateway router. I can no longer wi-fi connect to my HP printer, but the kids can print directly to it from their devices.

0 Likes
Zoey_DC
Enthusiast - Level 2

Sounds similar to what happened with me, some devices work fine, and others don't work at all...  I am thinking the only solution is to reset the router, but I wonder if I will be able to get back to the original router interface that allows for MAC Address filtering? Or if I will have to set it up using the interface at myfiosgateway.com rather than the interface I get when I use 192.168.1.1 to access the router, which does allow me to use MAC Address filtering...?

0 Likes
jr1901
Newbie

same problem here since yesterday.  weird thing is that i am now trying to using WPA2 but none of my phones can join the network...  keep saying password incorrect even though it is exactly as how i set it on the router

0 Likes
Edg1
Community Leader
Community Leader

@jr1901 wrote:

same problem here since yesterday.  weird thing is that i am now trying to using WPA2 but none of my phones can join the network...  keep saying password incorrect even though it is exactly as how i set it on the router


Try giving the router a hard reset. 

Edg1
Community Leader
Community Leader

That doesn't mean the router has been hacked. There is just a webpage certificate error. The page www.myfiosgateway.com is just the other site you can use to access the G1100. It just points you to 192.168.1.1. 

Something might have changed in your browser or it could be because of an update Verizon did. Go to Google and search website certificate error to see potential fixes. Either way it is still safe to login to your router.

joemfeliciano
Newbie

but its still does not work. the SSL needs to be Ckeared and then re-certified which can only be done by tier 3 level workers not anyone else

0 Likes