DHCP subnet problem
NetworkMom
Newbie

Hi,
I have a Quantum router which is running both the 5GHz and 2.4GHz networks. I try to keep most of my devices on the 2.4GHz network, with just a handful of devices on the 5GHz network. The 5GHz signal gets attenuated significantly in some rooms here, and the 2.4GHz signal is more reliable in those areas.

This generally works fine, but today I tried to set up a new device on the 2.4GHz network. It's connecting, and the router is showing the device in its tables, but for some reason it's being given the wrong network.

The DHCP settings are the default with a network of 192.168.1.0/255.255.255.0. Whenever my new device connects to the 2.4GHz network then it gets an address on 192.168.0.x, which is the wrong subnet, and consequently it can't connect to anything. If it connects on the 5GHz network then it gets an address of 192.168.1.x, which works correctly.

DHCP is only being served from the Quantum router (I have 2 other devices capable of doing DHCP, but both are disabled). I can't see any setting that suggests differences between serving addresses on the 2 interfaces.

Does anyone have any suggestions please?

0 Likes
3 Replies
Edg1
Community Leader
Community Leader

The new device’s wifi settings are definitely set to DHCP and not static?

0 Likes
NetworkMom
Newbie

Correct. Which is why the IP assignment works when connecting to the 5GHz network.

The new device is actually a Raspberry Pi. I could try correcting it manually (I could even set the IP to be static), but that's not a real solution. I'm thinking I might use wireshark and watch the DHCP negotiation, but I'm just expecting to see it hand out the weird IP, which won't tell me why it handed out that IP. The router shows the device as having the address in 192.168.0.x, so it's not like the device picked an address that's different to what the router allocated.

Another option is to change my netmask from the router to 255.255.0.0, but that seems like overkill.

0 Likes
Edg1
Community Leader
Community Leader

That is very strange. Changing the Pi’s network settings to static was actually what I was going to suggest. 

0 Likes