Re: Ethernet not working (fully), but WiFi works fine
Community Leader
Community Leader

@exploiteddna wrote:

Also one more thing..

I just decided to check out my device in the router settings. I found my PC and selected "View Device Details" (image 1 below)

By selecting "View device details" I was brought to this page here (image 2 below). Does anything look off/wrong here? What is "Bridge" for "Network connection" ??

So then I saw this "Test connectivity" button and decided to give it a go. When I run that test, this is the result (image 3 below)

so ummm.. that result isn't very reassuring

Are the other devices on the bridge too? Based upon your reply we (us helpers) will from there to figure out what to do next.

Re: Ethernet not working (fully), but WiFi works fine

This is the second time writing out this message.. the first one failed to send until i disconnected Ethernet and connected to Wifi.. but,  I digress. On with the real message:

So I brought my laptop home from work today. Wouldn't you believe.. when I connect the laptop to Ethernet, loads immediately. When I attempt the same connection on the desktop, I'm stuck on a blank page with "establishing secure connection.." in the status box at the bottom of the browser window.

So, laptop works fine, desktop does not

Both devices are running Windows 10 Pro (v2004), both recently updated from Windows 1909. Remember, on the desktop, I did a complete new install of Windows this past weekend, wiped and formatted the system drive and did a clean installation, which should have reset any windows defender/firewall settings back to default. The drivers for both of the NICs were reinstalled too.

Remember, the desktop has two ethernet NICs to choose from: Aquantia aqc111c 5gbe, and Intel I219-V. Previous testing showed no difference in their behavior.. 

One other thing to note, remember that is only being used for testing purposes because it's convenient. But there are plenty of other sites/programs that are failing to connect. I only use this one because it reliably replicates the problem.

So why is it that the desktop, with a clean installtion of system OS and network drivers, fails to connect to certain sites/programs, but the laptop device is (apparently) able to connect without a problem?? It's hard to imagine that windows defender/firewall is the problem, since both devices should have the same firewall settings that are default for this version of windows 10. Is it possible that this is a hardware issue? Why would these NICs be unable to make connection? I need a network guru to help me drill down and figure this out, because im running out of ideas.

Here are screenshots of the network devices for each device.



Any idead, suggestions, troubleshooting tips.. anything at all that could help, i'd be very appreciative... I really need to figure this out.

Re: Ethernet not working (fully), but WiFi works fine


I repeated a test that I had previously run prior to wiping the system drive and reinstalling the OS and drivers. Instead of plugging into the Aquantia AQC111C, I plugged into the Intel I219-V ethernet port. Rebooted the PC, opened the browser (Chrome), proceeded to which has been a reliable way to replicate the problem , and *poof*, just like that it connected without hesitation. I ran this exact test several weeks back and found no difference in behavior between the two ethernet ports/devices. 

So, this suggests something is "wrong" with the Aquantia AQC111C (which is supposed to be a "premium" device added to this motherboard to enable "Multi-Gig Ethernet speeds up of 5 GbE and 2.5 GbE") 

I wonder what the issue is, and/or why it's unable to make certain connections

Re: Ethernet not working (fully), but WiFi works fine
Enthusiast - Level 1

Perhaps the driver for the Aquantia needs updating?

I also noticed that on your router settings you're running at 2.4 rather than 5.  Is there a reason for that?

I've found Chrome to be almost impossible lately and often find a blank screen.  This seems to be the result of Chrome not liking the security settings of the site - or - Chrome's security settings are blocking the page.  If you go to the left icon on the url and right click it will bring you to security settings for the page in question.  I set them all to "allow", reload the page and it usually works.  But I'm getting really tired of Chrome after all these years.