G3100 Port Forwarding Doesn't Work
smuggle
Enthusiast - Level 2

G3100 doesn't let me forward ports either. Very sad this issue seems unresolved.

I really miss my g1100, it even had better signal in my living room. Wish I hadn't got the free upgrade to the g3100, I'd have been better off if I'd been allowed to keep my g1100.

Port forwarding is one of the most basic functions of a router for it to be this defective is nuts.

0 Likes
Reply
16 Replies
kh-gary
Moderator Emeritus

In order to keep discussion on the community current, this topic has been locked to prevent new replies. If you have a similar question or issue that you wish to discuss, then please feel free to post a new message on the most relevant board. Thanks!

Reply
smuggle
Enthusiast - Level 2

Still cannot get this to work, I really hate the g3100 making everything work "automatically" means not only does my hfs not work but if I want to host an online video game via old fashioned methods that doesn't work either.


I just want to be able to tell my computer and router that for one specific port I want that traffic to actually be open 😞 sigh. I still miss the g1100 and I wish I wasn't forced to "upgrade" my router.

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

G3100's PF function/interface got changed twice since you first posted this thread.

But the gist remains the same. See this and piggyback on the OP as necessary. https://forums.verizon.com/t5/fios-internet/port-forwarding-on-g3100-no-longer-working/m-p/921262/hi... 

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

@smuggle wrote:

Port forwarding is one of the most basic functions of a router for it to be this defective is nuts.


This is technically incorrect. A router is meant for routing. Port forwarding is the job of Network Address Translation (NAT), which is a mechanism NOT even found in a router until IPv4 exhaustion becomes a concern.

Could you describe exactly what are you trying to port forward?

0 Likes
Reply
smuggle
Enthusiast - Level 2

Port forwarding seems to mostly work in upnp IGD or dmz host (which I've turned on momentarily just to test this issue), but the entire advanced settings firewall port forwarding page of the settings menu has no functionality from what I've seen. I cannot get any port to register as open, no matter what I try. I could be doing it wrong, but given that I haven't found any instructions anywhere that work? Yet I have found many threads saying it doesn't work? I'm sort of just assuming it's broken.

I'd like to be able to get https://www.yougetsignal.com/tools/open-ports/ to tell me a port is open. 

I had it working just fine on my g1100, and if you offered me a swap my old g1100 for my new g3100 right this second I'd take it. (It's not that simple though since I changed plans and the rental of the new router is free due to a promotion.)

It's quite possible I'm doing something wrong but I'd like to use the below page to enter some choices that result in an open port in a port open test tool like https://www.yougetsignal.com/tools/open-ports/

The problem is either a flaw/bug or a setting on another page that needs to be changed. But I have tried all manner of things from changing the firewall's general security setting, to disabling upnp, to well really anything I can think of.

image

hmm, not sure why the image isn't showing up? when I hit edit the image appears perfectly.

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

What ports are you trying to forward? I will type up the instructions for you.

0 Likes
Reply
smuggle
Enthusiast - Level 2

Any of the ports in the upper range, the range that starts with some number in the 34000s ish and ends in the 65000s ish. The range usually used for some specific purpose with some arbitrarily chosen port.

Although by any, I mean exactly one port specifically chosen not all of them at once.

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

Ok. Which ports exactly are you trying to forward? Forwarding these many ports looks like you are looking for Port Triggering or UPnP functions rather than Port Forwarding.

0 Likes
Reply
smuggle
Enthusiast - Level 2

I'm not trying to forward many ports. I only want to forward one port. I can just choose it arbitrarily. Whatever steps exist to port forward 45678 would be the same steps as forwarding 54876. Either way it's one port.

It is possible that I should be using port triggering instead of port forwarding, but I've tried using that page as well to no avail either.

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

Sorry for the delayed response, I was attending to other businesses.

I just tested port forwarding a HTTP server at port 80 to the external port 60000, it works as expected.

On the port forwarding page, fill out all the boxes.

Application: a name for your port forwarding entry.

Original Port: WAN-facing port to be opened on router.

Protocol: TCP, UDP, or both.

Fwrd to Address: internal server address.

Fwrd to Port: listening port on the internal server.

Schedule: All time or create your own schedules.

0 Likes
Reply
smuggle
Enthusiast - Level 2

This is at least a clue to my problem. I need the port to be the same as itself. So in your example I would need to listen on port 60,000 not port 80.

This used to be possible on the old g1100 verizon router. Maybe it isn't possible anymore.

Although the configuration you suggest.... makes no sense because of the default rules including it.

https://myfiosgateway.com/#/adv/network/portrules/

This page states already that all http requests ALL at any port are already being forwarded to 80. So making a port forwarding rule to forward one port to 80, is redundant (except it does allow specifying my local device.)

I suppose it's possible that the g3100 is intentionally more restrictive than the g1100 and that there is no way to do what I want.

unfortunately the https://myfiosgateway.com/#/adv/network/portrules/ page is over my head and nothing I do on it has any effect. the https://myfiosgateway.com/#/adv/firewall/portforward page looks A LOT like the port forwarding page for the g1100 which is why I thought I might be able to figure it out myself, although I have clearly failed.

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

@smuggle wrote:

Although the configuration you suggest.... makes no sense because of the default rules including it.

https://myfiosgateway.com/#/adv/network/portrules/


Sorry, but you seem not understanding the purpose of Port Forwarding Rules page. NONE of the entries on the Port Forwarding Rules are applied in the router, and the settings in Port Forwarding Rules are irrelevant to configuring Port Forwarding.


@smuggle wrote:

This page states already that all http requests ALL at any port are already being forwarded to 80. So making a port forwarding rule to forward one port to 80, is redundant (except it does allow specifying my local device.)


No, nothing in the User Manual suggests this, and the actual mechanism is not as you described above.

Please just follow the steps I described above and do not configure the Port Forwarding Rules instead of Port Forwarding page.

0 Likes
Reply
smuggle
Enthusiast - Level 2

I did follow those steps, but I cannot set my hfs to port 80. Following the steps but choosing something other than 80 doesn't work. Of course setting it to 80 also doesn't work, but I never expected setting it to 80 to work since 80 is reserved for other purposes.

The reason I'm randomly suggesting it might have something to do with another page, is that, that seems logical, given I cannot solve the problem on the correct page.

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

Again, could you screenshot your Port Forwarding page to see?

Choosing ports other than 80 works. I have personally tested this in my mini Fios lab.

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

Could you give me some time to test myself whether G3100 allows the forwarding of ports higher than 35000?

0 Likes
Reply
smuggle
Enthusiast - Level 2

Saying nothing implied I would wait for additional replies, writing this message though to say that I will read additional replies, for some reason, now feels required, so I wrote it. Sure, if anyone could reply to this thread with steps/solutions/reasoning/fixes I'd certainly read them. I am just concerned no such solution exists.

0 Likes
Reply