G3100 doesn’t let my iMac go to sleep.
JS447
Enthusiast - Level 2

Hi All,

I upgraded to the g3100 about 6 weeks ago and for the most part it works as expected, except that when my iMac M1 goes to sleep it wakes up 5-10 min later almost every time. I don’t have any connection issues and power savings in the iMac is correct. It’s not a usb or Bluetooth issue I think, because Ive tried isolating keyboard and mouse. I never had this issue with the g1100.

Can anyone shed some light on the issue?

0 Likes
Reply
1 Solution
JS447
Enthusiast - Level 2

Latest Apple FW seems to have fixed the Bluetooth issues. 😃

View solution in original post

3 Replies
JS447
Enthusiast - Level 2

Just want to update the situation.
After more testing it seems that the Logitech mx3 mouse is the culprit when connected via Bluetooth. Apparently I didn’t disconnect the mouse when isolating devices yesterday, only the keyboard, so my bad. 
Sleep mode works fine when connected by logi unifying receiver though and hopefully Apple and Logitech will release a FW fix. Apparently, it’s a widespread issue with Monterey. 

dexman
Community Leader
Community Leader

I use BT mice with my computers (Microsoft Surface devices). I've gotten into the practice of turning the mice off when they won't be used for a while.

Would that be a viable option for the iMac/Logitech combination ? 🤔 

0 Likes
Reply
JS447
Enthusiast - Level 2

Latest Apple FW seems to have fixed the Bluetooth issues. 😃